summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5269fb0..d24bb1e 100644
--- a/meson.build
+++ b/meson.build
@@ -58,12 +58,18 @@ pcs = [
]
foreach pc : pcs
+ if pc[0] == 'xf86driproto'
+ subdir = 'X11/dri'
+ else
+ subdir = ''
+ endif
pkg.generate(
name : pc[0],
filebase : pc[0],
description : pc[0] + ' headers',
version : pc[1],
- install_dir : get_option('datadir') + '/pkgconfig'
+ install_dir : get_option('datadir') + '/pkgconfig',
+ subdirs : subdir,
)
endforeach