Age | Commit message (Collapse) | Author |
|
I kinda hate to do this, it was nice to have everything in one place.
However, the meson build wants to be able to wrap this module as a
dependency, and code that depends on these headers includes them in the
form:
#include <X11/Xfuncproto.h>
As a result, any include path meson can construct needs to point to the
root of a hierarchy that has the same path layout as an installed copy,
hence this change.
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
|
expose this as an array of 8 32-bit values.
Reviewed-by: Keith Packard <keithp@keithp.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
|
|
v2: [airlied] add get_active to monitor get
interface, to allow normal vs configuration
clients to see active vs all monitors. (r-b by keithp)
Reviewed-by: Dave Airlie <airlied@redhat.com>
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
This property represents the globally-unique identifier of the connected
display, if one is available.
Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
Reviewed-by: Andy Ritger <aritger@nvidia.com>
|
|
A provider object represents a GPU or virtual device that provides
rendering or output services to the X server. This protocol
allow controlling provider objects for output and offload slave devices.
v1.1: fix typo add missing define
v2: rename nProperties back to nAtoms, makes server simpler to c-n-p,
add missing Get request/reply
v3: bring back configure property, no point in diverging from the
output property code without good reason.
also fix typo pointed out on irc by rei4dan.
v3.1: drop cut-n-paste, increase RRNumberRequests
v4: reviewed by Aaron, address comments:
Fix provider error code
add missing notify, remove dri2 references, fix c-n-p issues.
v5: add provider change notify event with current role.
v5.1: fix cut-n-paste
v6:
document flags, fix whitespace, add better errors for SetProviderRoles,
add new events, fix pending language.
v6.1: add missing change notify event struct + missing padding
v7: fix a bunch more tab/spaces, add appendix sections for requests, events
and errors, remove multimaster flag in favour of max master counter,
move some members around to follow other events.
v7.1 fix maxMaster + wrong comment, one whitespace
v7.2 bump to being randr 1.4, fix some too generic names.
v7.3 remove dynamic flag, fix some language
v8 overhaul complete protocol, remove set provider roles, add specific
methods for setting offload sinks and output sources, add a list
of associated providers into the get provider info struct.
Earlier-review-by: Aaron Plattner <aplattner@nvidia.com>
Reviewed-by: Keith Packard <keithp@keithp.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
|
|
This patch reverts:
Revert "Make SetCrtcConfigs take flags bits to allow partial configuration changes"
This reverts commit 105a161a3f5fb67f5fe7e4119629d424672804aa.
Revert "Define new semantics for scanout pixmap destruction."
This reverts commit 0d32bb0780db35cec31e423faffa7061ec3e697f.
Revert "Fix spelling errors, add description of SCANOUTPIXMAPINFO fields."
This reverts commit 3e28d3098faa1a420cd0eb0474b2959cecc8813a.
Revert "Add some informative text about the reasons for the PCP and ST bits"
This reverts commit ebab32deea654d2ceb0538177e78d8ad48cf2a82.
Revert "RandR version 1.4 additions"
This reverts commit dd14a2275521b4cc50a588c95cc34cca7db51a91.
None of this was ever used in the X server and I think it should
probably be addressed in smaller pieces later.
Acked-by: Keith Packard <keithp@keithp.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
|
|
Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
Reviewed-by: Stéphane Marchesin <marcheu@chromium.org>
|
|
Instead of requiring a complete new configuration to be computed,
allow the client to send a partial configuration with only the changed
values included. This simplifies clients so that they need not change
things they don't understand.
This also removes the 'CurrentScanoutPixmap' hack as that is no longer
necessary.
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
This adds the specification and protocol header definitions for the
RandR 1.4 protocol changes, including
* Per crtc pixmaps and pixmap origins
* Sprite position and image transforms
* SetCrtcConfigs request
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
|
|
|
|
|
|
|
|
|
|
Conflicts:
randr.h
randrproto.h
randrproto.txt
|
|
|
|
|
|
|
|
Pending values are transferred to current values at mode set, allowing a
queue of values to accrue in preparation for the modeset operation while
still reporting valid 'current' values for applications.
The set of valid values is also available so applications can present
a reasonable list to the user during configuration.
I renumbered a bunch of requests to keep property requests sequential.
|
|
Output options will be controlled by properties instead.
Also found a few instances in randrproto.txt using the wrong
size for MODEINFO.
|
|
|
|
Switched from identifying source of mode line to listing which modes are
preferred by each output. This enables better CRTC sharing by making modes
less arbitrarily different.
|
|
|
|
Mode origins indicate the source of the mode information, from VESA timings,
user config or whatever.
Output options currently include only panel fitting options; more may be
added later (this field is 32 bits wide)
|
|
|
|
Fix RRNumberRequests
Rename errors to include RR to avoid conflicting with Xi.
Add RR to various request/reply structs (oops).
Remove nOutputs from SetCrtcConfigReq -- length is sufficient.
Remove bogus members from SetCrtcConfigReply.
Add MODEOPTION. Document protocol error encoding.
|
|
Missing CONNECTION values in encoding and header file.
|
|
Spec was missing a few things in the encoding section.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|