summaryrefslogtreecommitdiff
path: root/gnu/llvm/unittests/IR/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Stumpf <pascal@cvs.openbsd.org>2016-09-03 22:47:03 +0000
committerPascal Stumpf <pascal@cvs.openbsd.org>2016-09-03 22:47:03 +0000
commitc07c59953ad4d4f16e8c3a3e25692ad9657db3ea (patch)
treee5a516d9d25bf178ab50dad2aa60c32b8684d5ee /gnu/llvm/unittests/IR/CMakeLists.txt
parent62bc401a55deb1281a3a42cd4f08325a6839a171 (diff)
Use the space freed up by sparc and zaurus to import LLVM.
ok hackroom@
Diffstat (limited to 'gnu/llvm/unittests/IR/CMakeLists.txt')
-rw-r--r--gnu/llvm/unittests/IR/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/llvm/unittests/IR/CMakeLists.txt b/gnu/llvm/unittests/IR/CMakeLists.txt
new file mode 100644
index 00000000000..5aad8edc913
--- /dev/null
+++ b/gnu/llvm/unittests/IR/CMakeLists.txt
@@ -0,0 +1,41 @@
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ AsmParser
+ Core
+ Support
+ )
+
+set(IRSources
+ AsmWriterTest.cpp
+ AttributesTest.cpp
+ ConstantRangeTest.cpp
+ ConstantsTest.cpp
+ DebugInfoTest.cpp
+ DominatorTreeTest.cpp
+ IRBuilderTest.cpp
+ InstructionsTest.cpp
+ LegacyPassManagerTest.cpp
+ MDBuilderTest.cpp
+ MetadataTest.cpp
+ PassManagerTest.cpp
+ PatternMatch.cpp
+ TypeBuilderTest.cpp
+ TypesTest.cpp
+ UseTest.cpp
+ UserTest.cpp
+ ValueHandleTest.cpp
+ ValueMapTest.cpp
+ ValueTest.cpp
+ VerifierTest.cpp
+ WaymarkTest.cpp
+ )
+
+# HACK: Declare a couple of source files as optionally compiled to satisfy the
+# missing-file-checker in LLVM's weird CMake build.
+set(LLVM_OPTIONAL_SOURCES
+ ValueMapTest.cpp
+ )
+
+add_llvm_unittest(IRTests
+ ${IRSources}
+ )