summaryrefslogtreecommitdiff
path: root/gnu/usr.bin/cvs/configure.in
diff options
context:
space:
mode:
authorThorsten Lockert <tholo@cvs.openbsd.org>1996-05-06 22:51:25 +0000
committerThorsten Lockert <tholo@cvs.openbsd.org>1996-05-06 22:51:25 +0000
commitbac1187d8a913304d9f68dda4e48dccc866e2d80 (patch)
treea6d847632a9bd9feeb0d346163a9869ebdc4f4a5 /gnu/usr.bin/cvs/configure.in
parentf527edf90d162a57e7909ff3645cb0a6e34b8790 (diff)
Integrate local changes to CVS; remove files no longer part of the CVS
distribution
Diffstat (limited to 'gnu/usr.bin/cvs/configure.in')
-rw-r--r--gnu/usr.bin/cvs/configure.in34
1 files changed, 22 insertions, 12 deletions
diff --git a/gnu/usr.bin/cvs/configure.in b/gnu/usr.bin/cvs/configure.in
index 246c92fa29b..554a401fa6a 100644
--- a/gnu/usr.bin/cvs/configure.in
+++ b/gnu/usr.bin/cvs/configure.in
@@ -50,7 +50,7 @@ AC_TYPE_MODE_T
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_REPLACE_FUNCS(getwd mkdir rename strdup strstr dup2 strerror valloc waitpid memmove vasprintf strtoul)
-AC_CHECK_FUNCS(fchmod fsync ftime mkfifo putenv setvbuf vfork vprintf ftruncate timezone getpagesize fchdir sigaction sigprocmask sigvec sigsetmask sigblock)
+AC_CHECK_FUNCS(fchmod fsync ftime mkfifo putenv setvbuf vfork vprintf ftruncate timezone getpagesize initgroups fchdir sigaction sigprocmask sigvec sigsetmask sigblock)
AC_CHECK_FUNC(re_exec, :, LIBOBJS="$LIBOBJS regex.o")
AC_FUNC_UTIME_NULL
AC_SYS_LONG_FILE_NAMES
@@ -62,8 +62,8 @@ AC_CACHE_VAL(ccvs_cv_sys_working_fnmatch,
int
main ()
{
- exit ((fnmatch ("a", "a", FNM_FILE_NAME) == 0
- && fnmatch ("a", "b", FNM_FILE_NAME) == FNM_NOMATCH)
+ exit ((fnmatch ("a", "a", FNM_PATHNAME) == 0
+ && fnmatch ("a", "b", FNM_PATHNAME) == FNM_NOMATCH)
? 0 : 1);
}],
ccvs_cv_sys_working_fnmatch=yes,
@@ -116,7 +116,7 @@ AC_MSG_RESULT($krb_h)
if test -n "$krb_h"; then
krb_lib=
- AC_CHECK_LIB(krb,main,[krb_lib=yes krb_libdir=],
+ AC_CHECK_LIB(krb,printf,[krb_lib=yes krb_libdir=],
[if test "$cross_compiling" != yes && test -r $KRB4/lib/libkrb.a; then
krb_lib=yes krb_libdir=$KRB4/lib
fi])
@@ -124,7 +124,7 @@ if test -n "$krb_h"; then
AC_DEFINE(HAVE_KERBEROS)
test -n "${krb_libdir}" && LIBS="${LIBS} -L${krb_libdir}"
LIBS="${LIBS} -lkrb"
- AC_CHECK_LIB(des,main,[LIBS="${LIBS} -ldes"])
+ AC_CHECK_LIB(des,printf,[LIBS="${LIBS} -ldes"])
if test -n "$krb_incdir"; then
includeopt="${includeopt} -I$krb_incdir"
AC_SUBST(includeopt)
@@ -141,11 +141,11 @@ unset ac_cv_func_connect
AC_CHECK_FUNC(connect, :,
[case "$LIBS" in
*-lnsl*) ;;
-*) AC_CHECK_LIB(nsl_s, main) ;;
+*) AC_CHECK_LIB(nsl_s, printf) ;;
esac
case "$LIBS" in
*-lnsl*) ;;
-*) AC_CHECK_LIB(nsl, main) ;;
+*) AC_CHECK_LIB(nsl, printf) ;;
esac
case "$LIBS" in
*-lsocket*) ;;
@@ -164,8 +164,18 @@ AC_CHECK_FUNC(gethostname, :, LIBOBJS="$LIBOBJS hostname.o")
if test "$ac_cv_func_connect" = yes; then
AC_DEFINE(CLIENT_SUPPORT)
AC_DEFINE(SERVER_SUPPORT)
-# As far as I know this works on all machines which use configure (i.e. unix)
-AC_DEFINE(AUTH_SERVER_SUPPORT)
+# Define AUTH_SERVER_SUPPORT only if we could locate the crypt() function
+unset ac_cv_func_crypt
+AC_CHECK_FUNC(crypt, :,
+[case "$LIBS" in
+*-lcrypt*) ;;
+*) AC_CHECK_LIB(crypt, crypt) ;;
+esac
+unset ac_cv_func_crypt
+AC_CHECK_FUNCS(crypt)])
+ if test "$ac_cv_func_crypt" = yes; then
+ AC_DEFINE(AUTH_SERVER_SUPPORT)
+ fi
fi
test -f src/options.h && (
@@ -176,6 +186,6 @@ test -f src/options.h && (
)
AC_OUTPUT(Makefile lib/Makefile src/Makefile doc/Makefile \
- man/Makefile contrib/Makefile contrib/pcl-cvs/Makefile \
- examples/Makefile windows-NT/Makefile os2/Makefile \
- macintosh/Makefile stamp-h)
+ man/Makefile tools/Makefile tools/pcl-cvs/Makefile \
+ contrib/Makefile contrib/elib/Makefile \
+ windows-NT/Makefile os2/Makefile macintosh/Makefile stamp-h)