summaryrefslogtreecommitdiff
path: root/gnu/usr.bin/perl/ext/B/Makefile.PL
diff options
context:
space:
mode:
authorTodd C. Miller <millert@cvs.openbsd.org>2001-05-24 18:26:20 +0000
committerTodd C. Miller <millert@cvs.openbsd.org>2001-05-24 18:26:20 +0000
commit483d4e680bd2a6db14835b1b4d65be33488d532b (patch)
tree129a4c95425cb37ed928ef53a27eb7dce5de3345 /gnu/usr.bin/perl/ext/B/Makefile.PL
parent8757fe6728b9db37919ad703b336ebbbc84413aa (diff)
stock perl 5.6.1
Diffstat (limited to 'gnu/usr.bin/perl/ext/B/Makefile.PL')
-rw-r--r--gnu/usr.bin/perl/ext/B/Makefile.PL20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/usr.bin/perl/ext/B/Makefile.PL b/gnu/usr.bin/perl/ext/B/Makefile.PL
index cb9696bf416..dcf6a1db15b 100644
--- a/gnu/usr.bin/perl/ext/B/Makefile.PL
+++ b/gnu/usr.bin/perl/ext/B/Makefile.PL
@@ -1,5 +1,6 @@
use ExtUtils::MakeMaker;
use Config;
+use File::Spec;
my $e = $Config{'exe_ext'};
my $o = $Config{'obj_ext'};
@@ -29,8 +30,19 @@ sub post_constants {
"\nLIBS = $Config::Config{libs}\n"
}
-sub postamble {
-'
-B$(OBJ_EXT) : defsubs.h
-'
+sub upupfile {
+ File::Spec->catfile(File::Spec->updir,
+ File::Spec->updir, $_[0]);
+}
+
+sub MY::postamble {
+ my $op_h = upupfile('op.h');
+ my $cop_h = upupfile('cop.h');
+ my $noecho = shift->{NOECHO};
+"
+B\$(OBJ_EXT) : defsubs.h
+
+defsubs.h :: $op_h $cop_h
+ $noecho \$(NOOP)
+"
}