summaryrefslogtreecommitdiff
path: root/usr.bin/sudo/configure.in
diff options
context:
space:
mode:
authorTodd C. Miller <millert@cvs.openbsd.org>2002-01-16 18:09:14 +0000
committerTodd C. Miller <millert@cvs.openbsd.org>2002-01-16 18:09:14 +0000
commit974d053d7d6dc166e24f5feca3c0ceb85e6b6429 (patch)
treeb73b659f3b57b58ae8e05cfb90040cd1c24fdd0f /usr.bin/sudo/configure.in
parent3a5832d5aa39da12b1555cc9cdcaf4d2f7a97ded (diff)
update to sudo 1.6.4p2
Diffstat (limited to 'usr.bin/sudo/configure.in')
-rw-r--r--usr.bin/sudo/configure.in30
1 files changed, 29 insertions, 1 deletions
diff --git a/usr.bin/sudo/configure.in b/usr.bin/sudo/configure.in
index 30e1d1463ac..283fb185491 100644
--- a/usr.bin/sudo/configure.in
+++ b/usr.bin/sudo/configure.in
@@ -1,6 +1,6 @@
dnl
dnl Process this file with GNU autoconf to produce a configure script.
-dnl $Sudo: configure.in,v 1.342 2002/01/07 18:59:47 millert Exp $
+dnl $Sudo: configure.in,v 1.344 2002/01/15 22:47:29 millert Exp $
dnl
dnl Copyright (c) 1994-1996,1998-2002 Todd C. Miller <Todd.Miller@courtesan.com>
dnl
@@ -203,6 +203,19 @@ AC_ARG_WITH(devel, [ --with-devel add developement options],
;;
esac])
+AC_ARG_WITH(efence, [ --with-efence link with -lefence for malloc() debugging],
+[case $with_efence in
+ yes) echo 'Sudo will link with -lefence (Electric Fence)'
+ LIBS="${LIBS} -lefence"
+ if test -f /usr/local/lib/libefence.a; then
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
+ fi
+ ;;
+ no) ;;
+ *) echo "Ignoring unknown argument to --with-efence: $with_efence"
+ ;;
+esac])
+
AC_ARG_WITH(csops, [ --with-csops add CSOps standard options],
[case $with_csops in
yes) echo 'Adding CSOps standard options'
@@ -951,6 +964,21 @@ AC_ARG_ENABLE(authentication,
esac
], AC_MSG_RESULT(yes))
+AC_MSG_CHECKING(whether to disable use of POSIX saved ids)
+AC_ARG_ENABLE(saved-ids,
+[ --saved-ids Don't try to use POSIX saved ids],
+[ case "$enableval" in
+ yes) AC_MSG_RESULT(no)
+ ;;
+ no) AC_MSG_RESULT(yes)
+ AC_DEFINE(NO_SAVED_IDS, 1, [Define to avoid using POSIX saved ids.])
+ ;;
+ *) AC_MSG_RESULT(no)
+ echo "Ignoring unknown argument to --enable-saved-ids: $enableval"
+ ;;
+ esac
+], AC_MSG_RESULT(no))
+
AC_MSG_CHECKING(whether to disable shadow password support)
AC_ARG_ENABLE(shadow,
[ --disable-shadow Never use shadow passwords],