summaryrefslogtreecommitdiff
path: root/gnu/egcs/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/egcs/gcc/configure.in')
-rw-r--r--gnu/egcs/gcc/configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/egcs/gcc/configure.in b/gnu/egcs/gcc/configure.in
index b42d6ea3d00..936261f18d9 100644
--- a/gnu/egcs/gcc/configure.in
+++ b/gnu/egcs/gcc/configure.in
@@ -586,7 +586,7 @@ changequote([,])dnl
xm_file="alpha/xm-alpha-interix.h xm-interix.h"
xmake_file="x-interix alpha/t-pe"
- tmake_file="alpha/t-interix"
+ tmake_file="alpha/t-interix alpha/t-ieee"
if test x$enable_threads = xyes ; then
thread_file='posix'
fi
@@ -599,6 +599,7 @@ changequote([,])dnl
alpha*-*-linux-gnuecoff*)
tm_file="${tm_file} alpha/linux-ecoff.h alpha/linux.h"
target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-ieee"
gas=no
xmake_file=none
gas=yes gnu_ld=yes
@@ -606,7 +607,7 @@ changequote([,])dnl
alpha*-*-linux-gnulibc1*)
tm_file="${tm_file} alpha/elf.h alpha/linux.h alpha/linux-elf.h"
target_cpu_default="MASK_GAS"
- tmake_file="t-linux t-linux-gnulibc1 alpha/t-linux alpha/t-crtbe"
+ tmake_file="t-linux t-linux-gnulibc1 alpha/t-linux alpha/t-crtbe alpha/t-ieee"
extra_parts="crtbegin.o crtend.o"
xmake_file=none
gas=yes gnu_ld=yes
@@ -617,7 +618,7 @@ changequote([,])dnl
alpha*-*-linux-gnu*)
tm_file="${tm_file} alpha/elf.h alpha/linux.h alpha/linux-elf.h"
target_cpu_default="MASK_GAS"
- tmake_file="t-linux alpha/t-linux alpha/t-crtbe"
+ tmake_file="t-linux alpha/t-linux alpha/t-crtbe alpha/t-ieee"
extra_parts="crtbegin.o crtend.o"
xmake_file=none
gas=yes gnu_ld=yes
@@ -628,7 +629,7 @@ changequote([,])dnl
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
target_cpu_default="MASK_GAS"
- tmake_file="alpha/t-crtbe"
+ tmake_file="alpha/t-crtbe alpha/t-ieee"
extra_parts="crtbegin.o crtend.o"
xmake_file=none
gas=yes gnu_ld=yes
@@ -637,6 +638,7 @@ changequote([,])dnl
alpha*-*-openbsd*)
# default x-alpha is only appropriate for dec-osf.
target_cpu_default="MASK_GAS"
+ tmake_file="alpha/t-ieee"
;;
alpha*-dec-osf*)
@@ -649,6 +651,7 @@ changequote([,])dnl
extra_passes="mips-tfile mips-tdump"
fi
use_collect2=yes
+ tmake_file="alpha/t-ieee"
case $machine in
*-*-osf1*)
tm_file="${tm_file} alpha/osf.h alpha/osf12.h alpha/osf2or3.h"
@@ -675,6 +678,7 @@ changequote([,])dnl
;;
alpha*-*-vxworks*)
tm_file="${tm_file} dbx.h alpha/vxworks.h"
+ tmake_file="alpha/t-ieee"
if [ x$gas != xyes ]
then
extra_passes="mips-tfile mips-tdump"
@@ -685,7 +689,7 @@ changequote([,])dnl
alpha*-*-winnt*)
tm_file="${tm_file} alpha/alpha32.h alpha/win-nt.h winnt/win-nt.h"
xm_file="${xm_file} config/winnt/xm-winnt.h alpha/xm-winnt.h"
- tmake_file=t-libc-ok
+ tmake_file="t-libc-ok alpha/t-ieee"
xmake_file=winnt/x-winnt
extra_host_objs=oldnames.o
extra_gcc_objs="spawnv.o oldnames.o"
@@ -700,7 +704,7 @@ changequote([,])dnl
alpha*-dec-vms*)
tm_file=alpha/vms.h
xm_file="${xm_file} alpha/xm-vms.h"
- tmake_file=alpha/t-vms
+ tmake_file="alpha/t-vms alpha/t-ieee"
;;
arc-*-elf*)
extra_parts="crtinit.o crtfini.o"