summaryrefslogtreecommitdiff
path: root/gnu/egcs/gcc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/egcs/gcc/configure.in')
-rw-r--r--gnu/egcs/gcc/configure.in36
1 files changed, 25 insertions, 11 deletions
diff --git a/gnu/egcs/gcc/configure.in b/gnu/egcs/gcc/configure.in
index 42a97a4d28f..a015447b60d 100644
--- a/gnu/egcs/gcc/configure.in
+++ b/gnu/egcs/gcc/configure.in
@@ -396,10 +396,9 @@ GCC_FUNC_PRINTF_PTR
case "${host}" in
*-*-uwin*)
- # Under some versions of uwin, vfork is notoriously buggy and the test
- # can hang configure; on other versions, vfork exists just as a stub.
- # FIXME: This should be removed once vfork in uwin's runtime is fixed.
- ac_cv_func_vfork_works=no
+ AC_MSG_ERROR([
+*** UWIN may not be used as a host platform because
+*** linking with posix.dll is not allowed by the GNU GPL])
;;
esac
AC_FUNC_VFORK
@@ -756,15 +755,31 @@ changequote([,])dnl
tmake_file=arm/t-linux
gnu_ld=yes
;;
- arm*-*-linux-gnu*) # ARM GNU/Linux with ELF
+ arm*-*-linux-gnuoldld*) # ARM GNU/Linux with old ELF linker
xm_file=arm/xm-linux.h
xmake_file=x-linux
+ tm_file="arm/linux-oldld.h arm/linux-elf.h"
case $machine in
armv2*-*-*)
- tm_file=arm/linux-elf26.h
+ tm_file="arm/linux-elf26.h $tm_file"
;;
- *)
- tm_file=arm/linux-elf.h
+ esac
+ tmake_file="t-linux arm/t-linux"
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
+ gnu_ld=yes
+ case x${enable_threads} in
+ x | xyes | xpthreads | xposix)
+ thread_file='posix'
+ ;;
+ esac
+ ;;
+ arm*-*-linux-gnu*) # ARM GNU/Linux with ELF
+ xm_file=arm/xm-linux.h
+ xmake_file=x-linux
+ tm_file="arm/linux-elf.h"
+ case $machine in
+ armv2*-*-*)
+ tm_file="arm/linux-elf26.h $tm_file"
;;
esac
tmake_file="t-linux arm/t-linux"
@@ -1550,8 +1565,6 @@ changequote(,)dnl
i[34567]86-*-uwin*)
changequote([,])dnl
tm_file=i386/uwin.h
- xm_file="${xm_file} i386/xm-uwin.h"
- xm_defines="USG NO_STAB_H NO_SYS_SIGLIST"
tmake_file="i386/t-cygwin i386/t-uwin"
extra_objs=winnt.o
xmake_file=i386/x-cygwin
@@ -3736,7 +3749,8 @@ ALL_LINGUAS="en_UK"
# NLS support is still experimental, so disable it by default for now.
AC_ARG_ENABLE(nls,
- [ --enable-nls use Native Language Support (disabled by default)],
+[ --enable-nls use Native Language Support (disabled by default).
+ EXPERIMENTAL, see ABOUT-GCC-NLS.],
, enable_nls=no)
AM_GNU_GETTEXT