summaryrefslogtreecommitdiff
path: root/gnu/llvm/compiler-rt/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/llvm/compiler-rt/lib/CMakeLists.txt')
-rw-r--r--gnu/llvm/compiler-rt/lib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/llvm/compiler-rt/lib/CMakeLists.txt b/gnu/llvm/compiler-rt/lib/CMakeLists.txt
index 39082aa06d4..2020ee32d4f 100644
--- a/gnu/llvm/compiler-rt/lib/CMakeLists.txt
+++ b/gnu/llvm/compiler-rt/lib/CMakeLists.txt
@@ -59,3 +59,9 @@ endif()
if(COMPILER_RT_BUILD_LIBFUZZER)
compiler_rt_build_runtime(fuzzer)
endif()
+
+# It doesn't normally make sense to build runtimes when a sanitizer is enabled,
+# so we don't add_subdirectory the runtimes in that case. However, the opposite
+# is true for fuzzers that exercise parts of the runtime. So we add the fuzzer
+# directories explicitly here.
+add_subdirectory(scudo/standalone/fuzz)