summaryrefslogtreecommitdiff
path: root/gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt')
-rw-r--r--gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt b/gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt
index 2a560b8fcb7..c50ea0233fa 100644
--- a/gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt
+++ b/gnu/llvm/compiler-rt/lib/scudo/CMakeLists.txt
@@ -38,7 +38,8 @@ if (COMPILER_RT_HAS_GWP_ASAN)
# parsing mechanism of sanitizer_common. Once Scudo has its own flag parsing,
# and parses GwpAsan options, you can remove this dependency.
list(APPEND SCUDO_MINIMAL_OBJECT_LIBS RTGwpAsan RTGwpAsanOptionsParser
- RTGwpAsanBacktraceLibc)
+ RTGwpAsanBacktraceLibc
+ RTGwpAsanSegvHandler)
list(APPEND SCUDO_CFLAGS -DGWP_ASAN_HOOKS)
endif()