summaryrefslogtreecommitdiff
path: root/gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt')
-rw-r--r--gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt b/gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt
new file mode 100644
index 00000000000..e29787f8f42
--- /dev/null
+++ b/gnu/llvm/unittests/ExecutionEngine/MCJIT/CMakeLists.txt
@@ -0,0 +1,33 @@
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ IPO
+ MC
+ MCJIT
+ RuntimeDyld
+ ScalarOpts
+ Support
+ Target
+ nativecodegen
+ )
+
+set(MCJITTestsSources
+ MCJITTest.cpp
+ MCJITCAPITest.cpp
+ MCJITMemoryManagerTest.cpp
+ MCJITMultipleModuleTest.cpp
+ MCJITObjectCacheTest.cpp
+ )
+
+if(MSVC)
+ list(APPEND MCJITTestsSources MCJITTests.def)
+endif()
+
+add_llvm_unittest(MCJITTests
+ ${MCJITTestsSources}
+ )
+
+if(MINGW OR CYGWIN)
+ set_property(TARGET MCJITTests PROPERTY LINK_FLAGS -Wl,--export-all-symbols)
+endif()