summaryrefslogtreecommitdiff
path: root/gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL')
-rw-r--r--gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL b/gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL
new file mode 100644
index 00000000000..bf7e2f8acdf
--- /dev/null
+++ b/gnu/usr.bin/perl/dist/Thread-Semaphore/Makefile.PL
@@ -0,0 +1,40 @@
+# Module makefile for Thread::Semaphore (using ExtUtils::MakeMaker)
+
+require 5.008;
+
+use strict;
+use warnings;
+
+use ExtUtils::MakeMaker;
+
+# Construct make file
+WriteMakefile(
+ 'NAME' => 'Thread::Semaphore',
+ 'AUTHOR' => 'Jerry D. Hedden <jdhedden AT cpan DOT org>',
+ 'VERSION_FROM' => 'lib/Thread/Semaphore.pm',
+ 'ABSTRACT_FROM' => 'lib/Thread/Semaphore.pm',
+ 'PREREQ_PM' => {
+ 'threads::shared' => 0,
+ 'Scalar::Util' => 1.10,
+ 'Test::More' => 0.50,
+ },
+ 'INSTALLDIRS' => (($] < 5.011) ? 'perl' : 'site'),
+
+ ((ExtUtils::MakeMaker->VERSION() lt '6.25') ?
+ ('PL_FILES' => { }) : ()),
+ ((ExtUtils::MakeMaker->VERSION() gt '6.30') ?
+ ('LICENSE' => 'perl_5') : ()),
+);
+
+# Additional 'make' targets
+sub MY::postamble
+{
+ return <<'_EXTRAS_';
+fixfiles:
+ @dos2unix `cat MANIFEST`
+ @$(CHMOD) 644 `cat MANIFEST`
+ @$(CHMOD) 755 examples/*.pl
+_EXTRAS_
+}
+
+# EOF