summaryrefslogtreecommitdiff
path: root/gnu/usr.bin/texinfo/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/usr.bin/texinfo/configure.in')
-rw-r--r--gnu/usr.bin/texinfo/configure.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/usr.bin/texinfo/configure.in b/gnu/usr.bin/texinfo/configure.in
new file mode 100644
index 00000000000..1a5f1581a0a
--- /dev/null
+++ b/gnu/usr.bin/texinfo/configure.in
@@ -0,0 +1,39 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(texinfo.texi)
+
+dnl Checks for programs.
+AC_PROG_GCC_TRADITIONAL
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+AC_ISC_POSIX
+AC_MINIX
+
+dnl Checks for libraries.
+# Needed on sysV68 for sigblock, sigsetmask.
+AC_CHECK_LIB(bsd, sigblock)
+
+TERMLIBS=
+for termlib in curses termcap terminfo termlib ; do
+ AC_CHECK_LIB(${termlib}, tputs,
+ [TERMLIBS="${TERMLIBS} -l${termlib}"; break])
+done
+AC_SUBST(TERMLIBS)
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h termio.h string.h varargs.h \
+ sys/time.h sys/fcntl.h sys/ttold.h sys/ptem.h sys/file.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_OFF_T
+AC_C_CONST
+AC_STRUCT_TM
+
+dnl Checks for library functions.
+AC_FUNC_ALLOCA
+AC_FUNC_SETVBUF_REVERSED
+AC_CHECK_FUNCS(setvbuf getcwd memset bzero bcopy memcpy strchr strcasecmp \
+ strdup vfprintf vsprintf strerror sigprocmask sigsetmask)
+
+AC_OUTPUT(Makefile libtxi/Makefile makeinfo/Makefile info/Makefile util/Makefile emacs/Makefile)