summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fd5c1ea..3e7ff73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,9 +20,15 @@
# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
aclocaldir = $(datadir)/aclocal
-aclocal_DATA = xorgversion.m4 xorg-macros.m4
+aclocal_DATA = xorg-macros.m4
-EXTRA_DIST = $(aclocal_DATA) ChangeLog
+# Previous versions used to install xorgversion.m4, now integrated
+# into xorg-macros.m4. Explicitly remove that old file in order not
+# to have a macro defined in two different files.
+install-data-hook:
+ rm -f $(DESTDIR)$(aclocaldir)/xorgversion.m4
+
+EXTRA_DIST = ChangeLog
.PHONY: ChangeLog