summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-05-14 21:14:44 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-05-14 21:14:44 -0700
commit58bd34e6c3662ef06e9ef0dd78d69f003df42bdc (patch)
tree1369366f132fb58bb419fd6519ac4a3e5947aa9c /Makefile.am
parent8522c314da7537169996476fe5ba411f720a09fe (diff)
Convert testcase from bug 28045 into automake "make check" test
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 91893c4..c697271 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -68,3 +68,23 @@ ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
lint:
$(LINT) $(ALL_LINT_FLAGS) $(makedepend_SOURCES)
endif LINT
+
+### Test cases - mostly for bug fixes submitted with a test case so far
+TESTS =
+
+# Absolute path to srcdir & builddir top that test scripts can reference
+TEST_BUILDDIR_PATH = `cd $(top_builddir) && pwd`
+TEST_SRCDIR_PATH = `cd $(top_srcdir) && pwd`
+
+# Path to makedepend command being tested that can be found from test subdirs
+TESTS_ENVIRONMENT = MAKEDEPEND="$(TEST_BUILDDIR_PATH)/makedepend"
+
+# Path to writable testdirectory in build directory
+TESTS_ENVIRONMENT += test_builddir="$(TEST_BUILDDIR_PATH)/tests"
+
+# Path to testcase files in source directory
+TESTS_ENVIRONMENT += test_srcdir="$(TEST_SRCDIR_PATH)/tests"
+
+# Test for https://bugs.freedesktop.org/show_bug.cgi?id=28045
+TESTS += tests/28045/makedep.sh
+EXTRA_DIST += tests/28045/makedep.sh tests/28045/foo.cpp