summaryrefslogtreecommitdiff
path: root/app/luit/man/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2013-02-21 20:37:11 +0100
committerMatthieu Herrb <matthieu.herrb@laas.fr>2013-02-21 20:37:11 +0100
commitbf92adb413c678cf9583c52c3ba70eb470aa5164 (patch)
treef700b8da61251b6ede38c42fb6faeca152c24cc5 /app/luit/man/Makefile.am
parent367bdc28e2de747c962659517bcc8cbf09a9fd81 (diff)
parenta53cfe7d0e23b384475bf42e9a7c51eca1e9479d (diff)
Merge remote-tracking branch 'origin/master' into matthieu/xserver-1.13
Diffstat (limited to 'app/luit/man/Makefile.am')
-rw-r--r--app/luit/man/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/app/luit/man/Makefile.am b/app/luit/man/Makefile.am
new file mode 100644
index 000000000..4844a205a
--- /dev/null
+++ b/app/luit/man/Makefile.am
@@ -0,0 +1,35 @@
+#
+# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+#
+
+appmandir = $(APP_MAN_DIR)
+appman_PRE = luit.man
+appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+MAN_SUBSTS += -e 's|__locale_alias__|$(LOCALEALIASFILE)|g'
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@