summaryrefslogtreecommitdiff
path: root/app/setxkbmap/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-10 10:33:02 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-10 10:33:02 +0000
commit9bb462321e220f71af510f09ed719d142dbe0363 (patch)
tree53919f2274dd94a2fe5f2fd6d3be4295114eb610 /app/setxkbmap/Makefile.am
parent7405789380e33d36db0f929f044c14876f84c647 (diff)
update to setxkbmap 1.1.0
Diffstat (limited to 'app/setxkbmap/Makefile.am')
-rw-r--r--app/setxkbmap/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/app/setxkbmap/Makefile.am b/app/setxkbmap/Makefile.am
index 226d448ed..2c2bebf4c 100644
--- a/app/setxkbmap/Makefile.am
+++ b/app/setxkbmap/Makefile.am
@@ -23,7 +23,7 @@ bin_PROGRAMS = setxkbmap
XKBCONFIGROOT=@XKBCONFIGROOT@
-setxkbmap_CFLAGS = $(SETXKBMAP_CFLAGS) \
+AM_CFLAGS = $(SETXKBMAP_CFLAGS) \
-D__XKBDEFRULES__='"xorg"' \
-DDFLT_XKB_CONFIG_ROOT=\"$(XKBCONFIGROOT)\"
setxkbmap_LDADD = $(SETXKBMAP_LIBS)
@@ -38,9 +38,16 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog
CLEANFILES = $(appman_DATA)
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog
+
SED = sed
# Strings to replace in man pages
@@ -48,6 +55,7 @@ XORGRELSTRING = @PACKAGE_STRING@
XORGMANNAME = X Version 11
MAN_SUBSTS = \
+ -e 's|__xkbconfigroot__|"$(XKBCONFIGROOT)"|' \
-e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
-e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
-e 's|__xservername__|Xorg|g' \
@@ -64,3 +72,11 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(setxkbmap_SOURCES)
+endif LINT