summaryrefslogtreecommitdiff
path: root/app/twm/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-01-22 14:24:56 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-01-22 14:24:56 +0000
commit7656b71d604cfe7a9aa12a2b5b29df242c91fcd0 (patch)
treedeb773c4ec42dfec83f229d38e56a2882c1532ec /app/twm/configure.ac
parent2b0246b39266d69e920e43d49d8e98e21e2815ce (diff)
Update to twm 1.0.6. No functional change.
Diffstat (limited to 'app/twm/configure.ac')
-rw-r--r--app/twm/configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/app/twm/configure.ac b/app/twm/configure.ac
index ef9c4b49b..6f1cef730 100644
--- a/app/twm/configure.ac
+++ b/app/twm/configure.ac
@@ -20,14 +20,17 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([twm], [1.0.5],
+AC_INIT([twm], [1.0.6],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [twm])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
-
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
@@ -36,8 +39,11 @@ XORG_DEFAULT_OPTIONS
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-AC_CHECK_FILE([$srcdir/gram.c], [],
- [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
+if test ! -f "$srcdir/gram.c"; then
+ if test -z "$YACC_INST"; then
+ AC_MSG_ERROR([yacc not found - unable to compile gram.y])
+ fi
+fi
AC_PROG_LEX
AC_CHECK_FUNCS([mkstemp])