summaryrefslogtreecommitdiff
path: root/app/twm/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2021-08-29 18:51:33 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2021-08-29 18:51:33 +0000
commit6b7b3389cce5a660a9ecd7a1fb9d45f2f1e6e2dc (patch)
tree71f5ce8a55230acbc968e02f9df6759584ef5a1e /app/twm/src/Makefile.am
parentdd8941239e7e7f6312d2804a556ae31a5d0a5695 (diff)
Update to twm 1.0.11
Diffstat (limited to 'app/twm/src/Makefile.am')
-rw-r--r--app/twm/src/Makefile.am66
1 files changed, 33 insertions, 33 deletions
diff --git a/app/twm/src/Makefile.am b/app/twm/src/Makefile.am
index 092d8ce7a..75e3d4a01 100644
--- a/app/twm/src/Makefile.am
+++ b/app/twm/src/Makefile.am
@@ -30,41 +30,41 @@ dist_rc_DATA = system.twmrc
AM_CPPFLAGS = \
-DXVENDORNAME=\"The\ X.Org\ Foundation\" \
-DXORG_RELEASE=\"Release\ $(VERSION)\" \
- -DSYSTEM_INIT_FILE=\"${datadir}/X11/twm/system.twmrc\"
+ -DSYSTEM_INIT_FILE=\"${rcdir}/system.twmrc\"
-AM_CFLAGS = $(TWM_CFLAGS)
-twm_LDADD = $(TWM_LIBS)
+AM_CFLAGS = $(TWM_CFLAGS) $(XRANDR_CFLAGS)
+twm_LDADD = $(TWM_LIBS) $(XRANDR_LIBS)
twm_SOURCES = \
- add_window.c \
- add_window.h \
- cursor.c \
+ add_window.c \
+ add_window.h \
+ cursor.c \
deftwmrc.c \
- events.c \
- events.h \
- gc.c \
- gc.h \
- iconmgr.c \
- iconmgr.h \
- icons.c \
- icons.h \
- list.c \
- list.h \
- menus.c \
- menus.h \
- parse.c \
- parse.h \
- resize.c \
- resize.h \
- screen.h \
- session.c \
- session.h \
- twm.c \
- twm.h \
- util.c \
- util.h \
- version.c \
- version.h \
+ events.c \
+ events.h \
+ gc.c \
+ gc.h \
+ iconmgr.c \
+ iconmgr.h \
+ icons.c \
+ icons.h \
+ list.c \
+ list.h \
+ menus.c \
+ menus.h \
+ parse.c \
+ parse.h \
+ resize.c \
+ resize.h \
+ screen.h \
+ session.c \
+ session.h \
+ twm.c \
+ twm.h \
+ util.c \
+ util.h \
+ version.c \
+ version.h \
gram.y \
lex.l
@@ -77,8 +77,8 @@ deftwmrc.c: system.twmrc
echo ' * twm bindings file system.twmrc by the twm Makefile.' >>$@ ; \
echo ' */' >>$@ ; \
echo '' >>$@ ; \
- echo 'unsigned char *defTwmrc[] = {' >>$@ ; \
+ echo 'const unsigned char *defTwmrc[] = {' >>$@ ; \
$(SED) -f ${srcdir}/deftwmrc.sed < ${srcdir}/system.twmrc >>$@ ; \
- echo ' (unsigned char *) 0 };' >>$@
+ echo ' (const unsigned char *) 0 };' >>$@
EXTRA_DIST = deftwmrc.sed siconify.bm