summaryrefslogtreecommitdiff
path: root/app/xconsole/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 18:27:26 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 18:27:26 +0000
commit176b89fd540b47851b3d9e15ce96e339e2d4a6e0 (patch)
tree52245f6178382385e36ed289ae37500e184de483 /app/xconsole/configure.ac
parentaffc240dec4ee127fd8d45105ed580476cccf81b (diff)
Update to xconsole 1.0.4. No functional change.
Diffstat (limited to 'app/xconsole/configure.ac')
-rw-r--r--app/xconsole/configure.ac26
1 files changed, 17 insertions, 9 deletions
diff --git a/app/xconsole/configure.ac b/app/xconsole/configure.ac
index ee3776844..e5f069e6c 100644
--- a/app/xconsole/configure.ac
+++ b/app/xconsole/configure.ac
@@ -21,21 +21,31 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xconsole,[1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xconsole)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([xconsole],
+ [1.0.4],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [xconsole])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
-AC_PROG_CC
-AC_PROG_INSTALL
+AM_CONFIG_HEADER(config.h)
# Checks for pkg-config packages
PKG_CHECK_MODULES(XCONSOLE, xaw7 xmu xt x11)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
AC_SEARCH_LIBS(openpty, [util])
@@ -112,7 +122,5 @@ fi
AC_SUBST(privsep_user)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
AC_OUTPUT([Makefile])