summaryrefslogtreecommitdiff
path: root/app/xfwp/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-01-22 14:30:52 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-01-22 14:30:52 +0000
commitba6f3aa1205ba535a8f806f148c8b3d7e90c0fa2 (patch)
tree11ac30702643f1a93846548390e9b50b0f4cd470 /app/xfwp/configure.ac
parent7656b71d604cfe7a9aa12a2b5b29df242c91fcd0 (diff)
Update to xfwp 1.0.2
Diffstat (limited to 'app/xfwp/configure.ac')
-rw-r--r--app/xfwp/configure.ac39
1 files changed, 26 insertions, 13 deletions
diff --git a/app/xfwp/configure.ac b/app/xfwp/configure.ac
index 5e668c5d2..42195a3d6 100644
--- a/app/xfwp/configure.ac
+++ b/app/xfwp/configure.ac
@@ -21,26 +21,39 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xfwp,[1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xfwp)
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([xfwp], [1.0.2],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xfwp])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
-
-AC_PROG_CC
-AC_PROG_INSTALL
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+AC_CANONICAL_HOST
+case $host_os in
+ linux*|gnu*|*-gnu)
+ OS_CFLAGS="-D_XOPEN_SOURCE -D_BSD_SOURCE"
+ ;;
+ *)
+ OS_CFLAGS=
+ ;;
+esac
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XFWP, x11 ice xproxymngproto)
-AC_SUBST(XFWP_CFLAGS)
-AC_SUBST(XFWP_LIBS)
+PKG_CHECK_MODULES(XFWP, xproto ice xproxymngproto)
# Check for libraries needed for TCP sockets on some platforms
# and defines like BSD44SOCKETS needed on others
XTRANS_TCP_FLAGS
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT