summaryrefslogtreecommitdiff
path: root/app/xkbcomp/configure.ac
diff options
context:
space:
mode:
authorAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-01-11 20:56:41 +0000
committerAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-01-11 20:56:41 +0000
commit9ac5a1302296cc63925671b566af8c4618cb581e (patch)
treea57d391645c4a3c5b6f756bae61bd7c2fe25009f /app/xkbcomp/configure.ac
parente7e24b28c0e0b96461d93395184a8a34f10631ca (diff)
Update to xkbcomp 1.2.0.
ok matthieu@
Diffstat (limited to 'app/xkbcomp/configure.ac')
-rw-r--r--app/xkbcomp/configure.ac32
1 files changed, 23 insertions, 9 deletions
diff --git a/app/xkbcomp/configure.ac b/app/xkbcomp/configure.ac
index 2f3468fbb..c69230b78 100644
--- a/app/xkbcomp/configure.ac
+++ b/app/xkbcomp/configure.ac
@@ -20,23 +20,37 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xkbcomp,[1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xkbcomp)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([xkbcomp], [1.2.0],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xkbcomp])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
AC_PROG_YACC
-AC_PROG_INSTALL
+AC_PATH_PROG([YACC_INST], $YACC)
+AC_CHECK_FILE([$srcdir/xkbparse.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])])
+
+
+AC_CHECK_FUNCS([strdup strcasecmp])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XKBCOMP, x11 xkbfile)
-AC_SUBST(XKBCOMP_CFLAGS)
-AC_SUBST(XKBCOMP_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
+AC_ARG_WITH([xkb_config_root],
+ [AC_HELP_STRING([--with-xkb-config-root=<paths>],
+ [Set default XKB config root (default: ${datadir}/X11/xkb)])],
+ [XKBCONFIGROOT="$withval"],
+ [XKBCONFIGROOT='${datadir}/X11/xkb'])
+AC_SUBST([XKBCONFIGROOT])
+
AC_OUTPUT([Makefile])