summaryrefslogtreecommitdiff
path: root/app/xkbevd/configure.ac
diff options
context:
space:
mode:
authorAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-01-11 20:52:10 +0000
committerAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-01-11 20:52:10 +0000
commite7e24b28c0e0b96461d93395184a8a34f10631ca (patch)
tree8922a8c7ef84f7186d3cd922390503ec9d07b0e2 /app/xkbevd/configure.ac
parent2b1d42660028a323d384dd912baf49ef28e92f84 (diff)
Update to xkbevd 1.1.2. No functional change.
ok matthieu@
Diffstat (limited to 'app/xkbevd/configure.ac')
-rw-r--r--app/xkbevd/configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/app/xkbevd/configure.ac b/app/xkbevd/configure.ac
index 611861c8a..64862782d 100644
--- a/app/xkbevd/configure.ac
+++ b/app/xkbevd/configure.ac
@@ -1,5 +1,5 @@
dnl Copyright 2005 Red Hat, Inc.
-dnl
+dnl
dnl Permission to use, copy, modify, distribute, and sell this software and its
dnl documentation for any purpose is hereby granted without fee, provided that
dnl the above copyright notice appear in all copies and that both that
@@ -9,7 +9,7 @@ dnl advertising or publicity pertaining to distribution of the software without
dnl specific, written prior permission. Red Hat makes no
dnl representations about the suitability of this software for any purpose. It
dnl is provided "as is" without express or implied warranty.
-dnl
+dnl
dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
@@ -20,9 +20,14 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xkbevd], [1.1.1],
+AC_INIT([xkbevd], [1.1.2],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xkbevd])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -30,15 +35,15 @@ AM_MAINTAINER_MODE
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.8)
-
-AM_CONFIG_HEADER(config.h)
+XORG_DEFAULT_OPTIONS
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-AC_CHECK_FILE([$srcdir/cfgparse.c], [],
- [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile cfgparse.y])])
-
-XORG_DEFAULT_OPTIONS
+if test ! -f "cfgparse.c"; then
+ if test -z "$YACC_INST"; then
+ AC_MSG_ERROR([yacc not found - unable to compile cfgparse.y])
+ fi
+fi
# Checks for pkg-config packages
PKG_CHECK_MODULES(XKBEVD, xkbfile x11)