summaryrefslogtreecommitdiff
path: root/app/xman/Makefile.am
diff options
context:
space:
mode:
authorIngo Schwarze <schwarze@cvs.openbsd.org>2019-08-15 12:11:37 +0000
committerIngo Schwarze <schwarze@cvs.openbsd.org>2019-08-15 12:11:37 +0000
commit7954fc17f34e2f6e82597d8ffa37162b136163db (patch)
treed4e47ce56077130a317c3098522d4e672a3a7715 /app/xman/Makefile.am
parente59fc69af03802164a65f31a4050febc9bb48a1b (diff)
Retire xman(1).
It's totally broken (requires MLINKS which we removed long ago, relies on the old man.conf(5) format we stopped supporting long ago, Alfred Morgan reported additional bugs on bugs@, ...), it reimplements man(1) in a very poor way, and it lacks many useful features that man(1) in an xterm(1) readily provides, so fixing it would be a waste of time. matthieu@ deraadt@ krw@ agree with the direction.
Diffstat (limited to 'app/xman/Makefile.am')
-rw-r--r--app/xman/Makefile.am72
1 files changed, 0 insertions, 72 deletions
diff --git a/app/xman/Makefile.am b/app/xman/Makefile.am
deleted file mode 100644
index 1c6efc8dd..000000000
--- a/app/xman/Makefile.am
+++ /dev/null
@@ -1,72 +0,0 @@
-#
-# Copyright 2005 Red Hat, Inc.
-#
-# Permission to use, copy, modify, distribute, and sell this software and its
-# documentation for any purpose is hereby granted without fee, provided that
-# the above copyright notice appear in all copies and that both that
-# copyright notice and this permission notice appear in supporting
-# documentation, and that the name of Red Hat not be used in
-# advertising or publicity pertaining to distribution of the software without
-# specific, written prior permission. Red Hat makes no
-# representations about the suitability of this software for any purpose. It
-# is provided "as is" without express or implied warranty.
-#
-# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
-# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
-# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
-# PERFORMANCE OF THIS SOFTWARE.
-
-SUBDIRS = man
-bin_PROGRAMS = xman
-
-helpdir=@HELPDIR@
-dist_help_DATA = xman.help
-
-AM_CFLAGS = $(CWARNFLAGS) $(XMAN_CFLAGS) \
- -D_BSD_SOURCE -DHELPFILE=\"$(helpdir)/xman.help\"
-xman_LDADD = $(XMAN_LIBS)
-
-xman_SOURCES = \
- buttons.c \
- defs.h \
- globals.c \
- globals.h \
- handler.c \
- help.c \
- iconclosed.h \
- icon_help.h \
- icon_open.h \
- main.c \
- man.c \
- man.h \
- misc.c \
- ScrollByL.c \
- ScrollByL.h \
- ScrollByLP.h \
- search.c \
- tkfuncs.c \
- vendor.c \
- vendor.h
-
-# App default files
-
-DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
-
-appdefaultdir = @appdefaultdir@
-
-dist_appdefault_DATA = app-defaults/Xman
-
-MAINTAINERCLEANFILES = ChangeLog INSTALL
-
-.PHONY: ChangeLog INSTALL
-
-INSTALL:
- $(INSTALL_CMD)
-
-ChangeLog:
- $(CHANGELOG_CMD)
-
-dist-hook: ChangeLog INSTALL