summaryrefslogtreecommitdiff
path: root/app/xsetpointer/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2008-12-23 08:59:22 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2008-12-23 08:59:22 +0000
commit95e3168db842422e0246c09d7d232073b4f62663 (patch)
treefcfd107e1a26161334792c5c6c84a660f66ebef0 /app/xsetpointer/Makefile.am
parent9a0c348a60f5f3eca0d3bfb8e7a9a59374cd36f0 (diff)
Remove obsolete applications (replaced by xinput).
Diffstat (limited to 'app/xsetpointer/Makefile.am')
-rw-r--r--app/xsetpointer/Makefile.am69
1 files changed, 0 insertions, 69 deletions
diff --git a/app/xsetpointer/Makefile.am b/app/xsetpointer/Makefile.am
deleted file mode 100644
index 24a33f809..000000000
--- a/app/xsetpointer/Makefile.am
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Copyright 2005 Red Hat, Inc.
-#
-# Permission to use, copy, modify, distribute, and sell this software and its
-# documentation for any purpose is hereby granted without fee, provided that
-# the above copyright notice appear in all copies and that both that
-# copyright notice and this permission notice appear in supporting
-# documentation, and that the name of Red Hat not be used in
-# advertising or publicity pertaining to distribution of the software without
-# specific, written prior permission. Red Hat makes no
-# representations about the suitability of this software for any purpose. It
-# is provided "as is" without express or implied warranty.
-#
-# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
-# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
-# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
-# PERFORMANCE OF THIS SOFTWARE.
-
-bin_PROGRAMS = xsetpointer
-
-xsetpointer_CFLAGS = $(XSETPOINTER_CFLAGS)
-xsetpointer_LDADD = $(XSETPOINTER_LIBS)
-
-xsetpointer_SOURCES = \
- xsetpointer.c
-
-appman_PRE = \
- xsetpointer.man
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE) ChangeLog
-CLEANFILES = $(appman_DATA) ChangeLog
-
-.PHONY: ChangeLog
-
-ChangeLog:
- GIT_DIR=$(srcdir)/.git git-log > ChangeLog
-
-dist-hook: ChangeLog
-
-SED = sed
-
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xservername__|Xorg|g' \
- -e 's|__xconfigfile__|xorg.conf|g' \
- -e 's|__projectroot__|$(prefix)|g' \
- -e 's|__apploaddir__|$(appdefaultdir)|' \
- -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
- -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
- -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
- -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
- -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-.man.$(APP_MAN_SUFFIX):
- sed $(MAN_SUBSTS) < $< > $@