summaryrefslogtreecommitdiff
path: root/app/xsm/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 10:49:38 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 10:49:38 +0000
commit841f8331c93ff96bd798e9a74ba10fab155da5c5 (patch)
tree36661fb122f858a2f14b585a304bad58a2142628 /app/xsm/Makefile.am
parent8f41c760916495ea26d3c59795487ac6dfc77d75 (diff)
Importing from X.Org 7.2RC2
Diffstat (limited to 'app/xsm/Makefile.am')
-rw-r--r--app/xsm/Makefile.am126
1 files changed, 126 insertions, 0 deletions
diff --git a/app/xsm/Makefile.am b/app/xsm/Makefile.am
new file mode 100644
index 000000000..bad4d3bc2
--- /dev/null
+++ b/app/xsm/Makefile.am
@@ -0,0 +1,126 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xsm
+
+SYSTEM_INIT_DIR = $(libdir)/X11/xsm
+
+
+xsm_CFLAGS = $(XSM_CFLAGS) -DRSHCMD=\"@RSH@\" \
+ -DSYSTEM_INIT_FILE=\"$(SYSTEM_INIT_DIR)/system.xsm\"
+
+xsm_LDADD = $(XSM_LIBS)
+
+xsm_SOURCES = \
+ auth.c \
+ auth.h \
+ choose.c \
+ choose.h \
+ info.c \
+ info.h \
+ list.c \
+ list.h \
+ lock.c \
+ lock.h \
+ log.c \
+ log.h \
+ mainwin.c \
+ mainwin.h \
+ misc.c \
+ popup.c \
+ popup.h \
+ printhex.c \
+ prop.c \
+ prop.h \
+ remote.c \
+ restart.c \
+ restart.h \
+ save.c \
+ save.h \
+ saveutil.c \
+ saveutil.h \
+ signals.c \
+ xsm.c \
+ xsm.h \
+ xtwatch.c \
+ xtwatch.h
+
+appman_PRE = \
+ xsm.man
+
+# App default files (*.ad)
+
+appdefaultdir = @appdefaultdir@
+
+
+APPDEFAULTFILES = \
+ XSm
+
+SUFFIXES = .ad
+
+.ad:
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+# system init file
+
+systeminitdir = $(SYSTEM_INIT_DIR)
+
+systeminit_DATA = system.xsm
+
+#
+
+EXTRA_DIST = $(APPDEFAULTFILES:%=%.ad) globals.c system.xsm
+
+CLEANFILES = $(APPDEFAULTFILES)
+
+
+appmandir = $(APP_MAN_DIR)
+
+appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
+
+EXTRA_DIST += $(appman_PRE)
+CLEANFILES += $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES += .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@