summaryrefslogtreecommitdiff
path: root/app/xterm/configure.in
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-05-08 12:20:48 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-05-08 12:20:48 +0000
commitca9af72c4f2136d12227a7761f8963ec23ecbd64 (patch)
tree3468e497065da090767c30e4be2c9312726bafd4 /app/xterm/configure.in
parent44f352c57ed103ad391992fdd93821e97f5ef4f2 (diff)
Update to xterm 258. lightly tested by krw@, thanks.
Diffstat (limited to 'app/xterm/configure.in')
-rw-r--r--app/xterm/configure.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/app/xterm/configure.in b/app/xterm/configure.in
index 63f7c753a..33ea78102 100644
--- a/app/xterm/configure.in
+++ b/app/xterm/configure.in
@@ -1,4 +1,4 @@
-dnl $XTermId: configure.in,v 1.256 2010/01/04 21:41:10 tom Exp $
+dnl $XTermId: configure.in,v 1.262 2010/04/21 00:16:24 tom Exp $
dnl
dnl -----------------------------------------------------------------------------
dnl this file is part of xterm
@@ -280,7 +280,9 @@ AC_CHECK_HEADERS( \
X11/DECkeysym.h \
X11/Sunkeysym.h \
X11/XF86keysym.h \
+ X11/XKBlib.h \
X11/Xpoll.h \
+ X11/extensions/XKB.h \
)
CF_X_ATHENA
@@ -300,7 +302,10 @@ freebsd*|netbsd*|dragonfly*) # 2004/8/15 - revisit this if/when grantpt is known
;;
esac
+AC_CHECK_FUNCS(XkbQueryExtension)
+
CF_XKB_BELL_EXT
+
AC_CHECK_FUNCS(Xutf8LookupString, [],[
EXTRAHDRS="$EXTRAHDRS xutf8.h"
EXTRASRCS="$EXTRASRCS xutf8.c"
@@ -583,7 +588,7 @@ fi
AC_MSG_CHECKING(if you want saved-lines stored as a FIFO)
CF_ARG_DISABLE(fifo-lines,
- [ --enable-fifo-lines disable FIFO-storage for saved-lines],
+ [ --disable-fifo-lines disable FIFO-storage for saved-lines],
[enable_fifo_lines=no],
[enable_fifo_lines=yes])
AC_MSG_RESULT($enable_fifo_lines)
@@ -981,5 +986,8 @@ do
CPPFLAGS=`echo "$CPPFLAGS" | sed -e s/-D$cf_def//`
done
+CF_MAKE_TAGS
+CF_DISABLE_RPATH_HACK
+
### output Makefile and xtermcfg.h
AC_OUTPUT(Makefile)