summaryrefslogtreecommitdiff
path: root/app/xwininfo/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-11-25 21:55:10 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-11-25 21:55:10 +0000
commit5673405fda589b3fa44c760f6a7ad2da4736ac14 (patch)
tree96bae00132299d9f39ca723f3bd45b3bca499418 /app/xwininfo/configure.ac
parent7a133c3f48de4e64026aae06c02760ffe9f7908a (diff)
Update to xwininfo 1.1.1. rewritten to use XCB.
Diffstat (limited to 'app/xwininfo/configure.ac')
-rw-r--r--app/xwininfo/configure.ac48
1 files changed, 37 insertions, 11 deletions
diff --git a/app/xwininfo/configure.ac b/app/xwininfo/configure.ac
index b4b8785ff..8bf5b943d 100644
--- a/app/xwininfo/configure.ac
+++ b/app/xwininfo/configure.ac
@@ -21,28 +21,54 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xwininfo, [1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xwininfo)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([xwininfo], [1.1.1],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xwininfo])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
-AC_PROG_INSTALL
+AC_USE_SYSTEM_EXTENSIONS
XORG_DEFAULT_OPTIONS
AC_CHECK_FUNCS([strlcat])
+AC_FUNC_STRNLEN
+if test "x$ac_cv_func_strnlen_working" = xyes; then
+ AC_DEFINE(HAVE_STRNLEN, 1, [Define to 1 if you have a working strnlen function.])
+fi
+
+# Check for iconv in libc, then libiconv
+AC_SEARCH_LIBS([iconv], [iconv], [AC_DEFINE([HAVE_ICONV], 1,
+ [Define to 1 if you have the iconv() function])])
+
+# Allow using xcb-icccm, but don't make it the default while the API is
+# still being changed.
+AC_MSG_CHECKING([whether to use xcb-icccm library])
+AC_ARG_WITH([xcb-icccm],
+ [AS_HELP_STRING([--with-xcb-icccm],
+ [use xcb-icccm (default: no)])],
+ [], [with_xcb_icccm=no])
+AC_MSG_RESULT([$with_xcb_icccm])
+if test "x$with_xcb_icccm" != xno ; then
+ AC_DEFINE([USE_XCB_ICCCM], 1,
+ [Define to 1 to call xcb-icccm library functions instead of local replacements])
+ xcb_icccm_pc="xcb-icccm"
+fi
+
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XWININFO, xext x11)
-AC_SUBST(XWININFO_CFLAGS)
-AC_SUBST(XWININFO_LIBS)
+PKG_CHECK_MODULES(XWININFO, [xcb >= 1.6] xcb-shape ${xcb_icccm_pc})
+
+# Even when using xcb, xproto is still required for Xfuncproto.h
+# and libX11 headers for cursorfont.h
+PKG_CHECK_MODULES(XLIB, x11 [xproto >= 7.0.17])
+XWININFO_CFLAGS="${XWININFO_CFLAGS} ${XLIB_CFLAGS}"
AC_OUTPUT([Makefile])