summaryrefslogtreecommitdiff
path: root/app/xwininfo/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2013-05-31 19:57:14 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2013-05-31 19:57:14 +0000
commit893ac1c025ec1aac6ef32d1741b33e619e546822 (patch)
treeaee5505f6c49d6d0c124119b5a03cc0e932f7d92 /app/xwininfo/configure.ac
parentc7aa701233375461de4e986bf0526c70b5e5baee (diff)
Update to xwininfo 1.1.3
Diffstat (limited to 'app/xwininfo/configure.ac')
-rw-r--r--app/xwininfo/configure.ac30
1 files changed, 15 insertions, 15 deletions
diff --git a/app/xwininfo/configure.ac b/app/xwininfo/configure.ac
index b86aa20f5..b28dd894a 100644
--- a/app/xwininfo/configure.ac
+++ b/app/xwininfo/configure.ac
@@ -1,6 +1,6 @@
dnl Copyright 2005 Red Hat, Inc.
-dnl
+dnl
dnl Permission to use, copy, modify, distribute, and sell this software and its
dnl documentation for any purpose is hereby granted without fee, provided that
dnl the above copyright notice appear in all copies and that both that
@@ -10,7 +10,7 @@ dnl advertising or publicity pertaining to distribution of the software without
dnl specific, written prior permission. Red Hat makes no
dnl representations about the suitability of this software for any purpose. It
dnl is provided "as is" without express or implied warranty.
-dnl
+dnl
dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
@@ -21,36 +21,35 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xwininfo], [1.1.2],
+AC_INIT([xwininfo], [1.1.3],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xwininfo])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_USE_SYSTEM_EXTENSIONS
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+AM_ICONV
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.8)
-
-AC_CONFIG_HEADERS([config.h])
-
-AC_USE_SYSTEM_EXTENSIONS
-
XORG_DEFAULT_OPTIONS
+# Checks for library functions
AC_CHECK_FUNCS([strlcat])
+# Use POSIX strnlen or the implementation supplied in this module
AC_FUNC_STRNLEN
if test "x$ac_cv_func_strnlen_working" = xyes; then
AC_DEFINE(HAVE_STRNLEN, 1, [Define to 1 if you have a working strnlen function.])
fi
-# Check for iconv in libc, then libiconv
-AC_SEARCH_LIBS([iconv], [iconv], [AC_DEFINE([HAVE_ICONV], 1,
- [Define to 1 if you have the iconv() function])])
-
-# Allow using xcb-icccm, but don't make it the default while the API is
-# still being changed.
+# Define a configure option for using the XCB ICCCM helper functions
AC_MSG_CHECKING([whether to use xcb-icccm library])
AC_ARG_WITH([xcb-icccm],
[AS_HELP_STRING([--with-xcb-icccm],
@@ -63,13 +62,14 @@ if test "x$with_xcb_icccm" != xno ; then
xcb_icccm_pc='xcb-icccm >= 0.3.8'
fi
-# Checks for pkg-config packages
+# Obtain compiler/linker options for xwininfo dependencies
PKG_CHECK_MODULES(XWININFO, [xcb >= 1.6] xcb-shape ${xcb_icccm_pc})
# Even when using xcb, xproto is still required for Xfuncproto.h
# and libX11 headers for cursorfont.h
PKG_CHECK_MODULES(XLIB, x11 [xproto >= 7.0.17])
XWININFO_CFLAGS="${XWININFO_CFLAGS} ${XLIB_CFLAGS}"
+XWININFO_LIBS="${XWININFO_LIBS} ${LIBICONV}"
AC_CONFIG_FILES([
Makefile