summaryrefslogtreecommitdiff
path: root/dist/libxcb/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2012-11-22 20:31:34 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2012-11-22 20:31:34 +0000
commit5cc22f3ebb0e7e2c512088be308c666e695daec4 (patch)
tree1f0fc03bf4f47ec2d71309b70d97499cc73eeb1b /dist/libxcb/configure.ac
parent0020ec3315ff8cb6aeae2358cd40dcb2940198dc (diff)
Update to libxcb 1.9.0.
tested by ajacoutot@ and naddy@ on a full ports build
Diffstat (limited to 'dist/libxcb/configure.ac')
-rw-r--r--dist/libxcb/configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/dist/libxcb/configure.ac b/dist/libxcb/configure.ac
index e94e32c7b..736438305 100644
--- a/dist/libxcb/configure.ac
+++ b/dist/libxcb/configure.ac
@@ -1,11 +1,18 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
+# Initialize Autoconf
AC_PREREQ(2.57)
AC_INIT([libxcb],
- 1.8.1,
+ 1.9,
[xcb@lists.freedesktop.org])
AC_CONFIG_SRCDIR([xcb.pc.in])
+# Set common system defines for POSIX extensions, such as _GNU_SOURCE
+# Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
+# to avoid autoconf errors.
+AC_USE_SYSTEM_EXTENSIONS
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -110,6 +117,13 @@ dnl check for support for Solaris Trusted Extensions
AC_CHECK_HEADERS([tsol/label.h])
AC_CHECK_FUNCS([is_system_labeled])
+dnl check for IOV_MAX, and fall back to UIO_MAXIOV on BSDish systems
+AC_CHECK_DECL([IOV_MAX], [],
+ [AC_CHECK_DECL([UIO_MAXIOV], [AC_DEFINE([IOV_MAX], [UIO_MAXIOV])],
+ [AC_DEFINE([IOV_MAX], [16], [Define if not provided by <limits.h>])],
+ [[#include <sys/uio.h>]])],
+ [[#include <limits.h>]])
+
xcbincludedir='${includedir}/xcb'
AC_SUBST(xcbincludedir)