summaryrefslogtreecommitdiff
path: root/driver/xf86-input-keyboard/configure.ac
diff options
context:
space:
mode:
authorAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-05-30 10:52:59 +0000
committerAlexandr Shadchin <shadchin@cvs.openbsd.org>2011-05-30 10:52:59 +0000
commit8a451c43839c0f0a10750371d9f75d79b3fe6d59 (patch)
treee7e0c3d05aeab297ae65f866db4929842e188677 /driver/xf86-input-keyboard/configure.ac
parent903ab7c78761b5fa7f61f9f969063c984b52cd01 (diff)
If you do not have XkbOptions in xorg.conf, it is automatically set to
"terminate: ctrl_alt_bksp" (only if XENOCARA_USE_XKEYBOARD_CONFIG=Yes) tested ajacoutot@, ok matthieu@
Diffstat (limited to 'driver/xf86-input-keyboard/configure.ac')
-rw-r--r--driver/xf86-input-keyboard/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/driver/xf86-input-keyboard/configure.ac b/driver/xf86-input-keyboard/configure.ac
index 869283643..302d53710 100644
--- a/driver/xf86-input-keyboard/configure.ac
+++ b/driver/xf86-input-keyboard/configure.ac
@@ -88,6 +88,15 @@ AM_CONDITIONAL(HURD, [test "x$IS_HURD" = xyes])
DRIVER_NAME=kbd
AC_SUBST([DRIVER_NAME])
+AC_ARG_ENABLE(xkeyboard-config,
+ AS_HELP_STRING([--enable-xkeyboard-config],
+ [Enable using xkeyboard-config (default: disabled)]),
+ [ XKEYBOARD_CONFIG="${enableval}" ],
+ [ XKEYBOARD_CONFIG="no" ])
+if test "x$XKEYBOARD_CONFIG" = xyes ; then
+ AC_DEFINE(USE_XKEYBOARD_CONFIG, 1, [Enable using xkeyboard-config])
+fi
+
AC_CONFIG_FILES([Makefile
src/Makefile
man/Makefile])