summaryrefslogtreecommitdiff
path: root/driver/xf86-video-cirrus/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:02:21 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:02:21 +0000
commit7410a84ea1d25a68751e62a5c999de4841b03873 (patch)
treefea59b0b401cfe73f15077310cc4fff9fc85a671 /driver/xf86-video-cirrus/src/Makefile.am
parent0e6a565ce2fedbfa0c5a6134064bd7eed7bf9cb8 (diff)
Importing xf86-video-cirrus 1.1.0
Diffstat (limited to 'driver/xf86-video-cirrus/src/Makefile.am')
-rw-r--r--driver/xf86-video-cirrus/src/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/driver/xf86-video-cirrus/src/Makefile.am b/driver/xf86-video-cirrus/src/Makefile.am
new file mode 100644
index 000000000..61b37c82b
--- /dev/null
+++ b/driver/xf86-video-cirrus/src/Makefile.am
@@ -0,0 +1,58 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@
+
+cirrus_drv_la_LTLIBRARIES = cirrus_drv.la
+cirrus_drv_la_LDFLAGS = -module -avoid-version
+cirrus_drv_ladir = @moduledir@/drivers
+cirrus_drv_la_SOURCES = \
+ cir_dga.c \
+ cir_driver.c \
+ cir.h \
+ CirrusClk.c \
+ cir_shadow.c
+
+cirrus_alpine_la_LTLIBRARIES = cirrus_alpine.la
+cirrus_alpine_la_LDFLAGS = -module -avoid-version
+cirrus_alpine_ladir = @moduledir@/drivers
+cirrus_alpine_la_SOURCES = \
+ alp_driver.c \
+ alp.h \
+ alp_hwcurs.c \
+ alp_i2c.c \
+ alp_xaa.c \
+ alp_xaam.c
+
+cirrus_laguna_la_LTLIBRARIES = cirrus_laguna.la
+cirrus_laguna_la_LDFLAGS = -module -avoid-version
+cirrus_laguna_ladir = @moduledir@/drivers
+cirrus_laguna_la_SOURCES = \
+ lg_driver.c \
+ lg.h \
+ lg_hwcurs.c \
+ lg_i2c.c \
+ lg_xaa.c \
+ lg_xaa.h