summaryrefslogtreecommitdiff
path: root/driver/xf86-video-mga/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2022-07-15 14:33:48 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2022-07-15 14:33:48 +0000
commit58af6da24cfb1325ab8dcfc3bc1bfadd49f9ac41 (patch)
tree3beeff4dd6f13fb385695d6164ac6b580ff70148 /driver/xf86-video-mga/configure.ac
parent03578fd2ec31e84fdcf2fecc541753f3dcd1ae79 (diff)
Update xf86-video-mga to version 2.0.1
Diffstat (limited to 'driver/xf86-video-mga/configure.ac')
-rw-r--r--driver/xf86-video-mga/configure.ac23
1 files changed, 14 insertions, 9 deletions
diff --git a/driver/xf86-video-mga/configure.ac b/driver/xf86-video-mga/configure.ac
index 686a6216c..1b4b6d6f2 100644
--- a/driver/xf86-video-mga/configure.ac
+++ b/driver/xf86-video-mga/configure.ac
@@ -23,7 +23,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xf86-video-mga],
- [2.0.0],
+ [2.0.1],
[https://gitlab.freedesktop.org/xorg/driver/xf86-video-mga/issues],
[xf86-video-mga])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -38,8 +38,7 @@ XORG_DEFAULT_OPTIONS
AC_CONFIG_AUX_DIR(.)
# Initialize Automake
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
-AM_MAINTAINER_MODE
+AM_INIT_AUTOMAKE([foreign dist-xz])
# Initialize libtool
AC_DISABLE_STATIC
@@ -77,12 +76,18 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
# Checks for libraries.
if test "x$DRI" != xno; then
- AC_CHECK_FILE([${sdkdir}/dri.h],
- [have_dri_h="yes"], [have_dri_h="no"])
- AC_CHECK_FILE([${sdkdir}/sarea.h],
- [have_sarea_h="yes"], [have_sarea_h="no"])
- AC_CHECK_FILE([${sdkdir}/dristruct.h],
- [have_dristruct_h="yes"], [have_dristruct_h="no"])
+ if test "$cross_compiling" = no; then
+ AC_CHECK_FILE([${sdkdir}/dri.h],
+ [have_dri_h="yes"], [have_dri_h="no"])
+ AC_CHECK_FILE([${sdkdir}/sarea.h],
+ [have_sarea_h="yes"], [have_sarea_h="no"])
+ AC_CHECK_FILE([${sdkdir}/dristruct.h],
+ [have_dristruct_h="yes"], [have_dristruct_h="no"])
+ else
+ have_dri_h="yes"
+ have_sarea_h="yes"
+ have_dristruct_h="yes"
+ fi
fi
AC_MSG_CHECKING([whether to include DRI support])