summaryrefslogtreecommitdiff
path: root/driver/xf86-video-mga/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2016-04-04 20:37:59 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2016-04-04 20:37:59 +0000
commita06290dfa1223be3d37bda30e4f11135cd567905 (patch)
tree691db1ee99146f521629c99320ca6cee17ee783b /driver/xf86-video-mga/configure.ac
parentf6304078dc618a750a2afd1be9e3fc6643beb0c3 (diff)
Fix EXA detection.
As of 1.17.2, the xserver is more picky about the order in which headers are included. We need to account for this in order for the compile time exa.h check to succeed. Patch from Matthew Rezny upstreams.
Diffstat (limited to 'driver/xf86-video-mga/configure.ac')
-rw-r--r--driver/xf86-video-mga/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/driver/xf86-video-mga/configure.ac b/driver/xf86-video-mga/configure.ac
index 06f143081..22959e18e 100644
--- a/driver/xf86-video-mga/configure.ac
+++ b/driver/xf86-video-mga/configure.ac
@@ -159,7 +159,8 @@ if test "x$EXA" = xyes; then
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
AC_CHECK_HEADER(exa.h,
- [have_exa_h="yes"], [have_exa_h="no"])
+ [have_exa_h="yes"], [have_exa_h="no"],
+ [#include "xorg-server.h"])
CPPFLAGS="$SAVE_CPPFLAGS"
else
AC_MSG_RESULT(no)
@@ -170,6 +171,7 @@ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
if test "x$have_exa_h" = xyes; then
AC_MSG_CHECKING([whether EXA version is at least 2.0.0])
AC_PREPROC_IFELSE([AC_LANG_PROGRAM([[
+#include "xorg-server.h"
#include "exa.h"
#if EXA_VERSION_MAJOR < 2
#error OLD EXA!