summaryrefslogtreecommitdiff
path: root/driver/xf86-video-suncg6/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:15:34 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:15:34 +0000
commitc6eab3e9811ee497c7bc59c98e0a048e8c4064e0 (patch)
treed75810a602df70ce41580cde079403857fd0a5e2 /driver/xf86-video-suncg6/src/Makefile.am
parent29088128d6da907cb480b0d8495a0b2f2d430f30 (diff)
Importing xf86-video-suncg6 1.1.0
Diffstat (limited to 'driver/xf86-video-suncg6/src/Makefile.am')
-rw-r--r--driver/xf86-video-suncg6/src/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/driver/xf86-video-suncg6/src/Makefile.am b/driver/xf86-video-suncg6/src/Makefile.am
new file mode 100644
index 000000000..21a367c04
--- /dev/null
+++ b/driver/xf86-video-suncg6/src/Makefile.am
@@ -0,0 +1,35 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@
+suncg6_drv_la_LTLIBRARIES = suncg6_drv.la
+suncg6_drv_la_LDFLAGS = -module -avoid-version
+suncg6_drv_ladir = @moduledir@/drivers
+
+suncg6_drv_la_SOURCES = \
+ cg6_cursor.c \
+ cg6_driver.c \
+ cg6.h \
+ cg6_regs.h