summaryrefslogtreecommitdiff
path: root/font/misc-ethiopic/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-07-25 12:05:00 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-07-25 12:05:00 +0000
commita7e1cee73d0a4b4acac5e86b31d669169e40f02f (patch)
tree130fdcff6227e43c06c4f4d595a865edf9bf0500 /font/misc-ethiopic/Makefile.am
parentef6e8f8358a734c9d6e9398f8d5a99f352125132 (diff)
A batch of font packages updates, only build-system related:
font-adobe-100dpi 1.0.1 font-adobe-75dpi 1.0.1 font-adobe-utopia-100dpi 1.0.2 font-adobe-utopia-75dpi 1.0.2 font-adobe-utopia-type1 1.0.2 font-arabic-misc 1.0.1 font-bh-100dpi 1.0.1 font-bh-75dpi 1.0.1 font-bh-lucidatypewriter-100dpi 1.0.1 font-bh-lucidatypewriter-75dpi 1.0.1 font-bh-ttf 1.0.1 font-bh-type1 1.0.1 font-bitstream-100dpi 1.0.1 font-bitstream-75dpi 1.0.1 font-bitstream-type1 1.0.1 font-cronyx-cyrillic 1.0.1 font-cursor-misc 1.0.1 font-daewoo-misc 1.0.1 font-dec-misc 1.0.1 font-ibm-type1 1.0.1 font-isas-misc 1.0.1 font-jis-misc 1.0.1 font-micro-misc 1.0.1 font-misc-cyrillic 1.0.1 font-misc-ethiopic 1.0.1 font-misc-meltho 1.0.1 font-mutt-misc 1.0.1 font-screen-cyrillic 1.0.2 font-sony-misc 1.0.1 font-sun-misc 1.0.1 font-winitzki-cyrillic 1.0.1 font-xfree86-type1 1.0.2
Diffstat (limited to 'font/misc-ethiopic/Makefile.am')
-rw-r--r--font/misc-ethiopic/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/font/misc-ethiopic/Makefile.am b/font/misc-ethiopic/Makefile.am
index eeffe3292..80bcd0e82 100644
--- a/font/misc-ethiopic/Makefile.am
+++ b/font/misc-ethiopic/Makefile.am
@@ -25,19 +25,31 @@ ttffont_DATA = GohaTibebZemen.ttf
otffontdir = @OTFFONTDIR@
otffont_DATA = GohaTibebZemen.otf
-EXTRA_DIST = $(ttffont_DATA) $(otffont_DATA) license.txt autogen.sh
+# Used by RUN_FCCACHE
+fontdir = $(ttffontdir) $(otffontdir)
+
+EXTRA_DIST = $(ttffont_DATA) $(otffont_DATA) license.txt
install-data-hook:
@rm -f $(DESTDIR)$(ttffontdir)/fonts.scale
$(MKFONTSCALE) $(DESTDIR)$(ttffontdir)
@rm -f $(DESTDIR)$(ttffontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(ttffontdir)
- $(FCCACHE) $(DESTDIR)$(ttffontdir)
@rm -f $(DESTDIR)$(otffontdir)/fonts.scale
$(MKFONTSCALE) $(DESTDIR)$(otffontdir)
@rm -f $(DESTDIR)$(otffontdir)/font.dir
$(MKFONTDIR) $(DESTDIR)$(otffontdir)
- $(FCCACHE) $(DESTDIR)$(otffontdir)
+ @RUN_FCCACHE@
distuninstallcheck:
@:
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog