summaryrefslogtreecommitdiff
path: root/font/misc-ethiopic/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 16:03:37 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 16:03:37 +0000
commitda112f01a28fa90b67722143d5ce088ec8bbc0da (patch)
tree8dbb99bfe7e3d050a8077bef60dccfd8bb0ca21f /font/misc-ethiopic/configure.ac
parentb9ae9240c81bfacfe9f933ffcb0e883534346de6 (diff)
Importing font-misc-ethiopic 1.0.0
Diffstat (limited to 'font/misc-ethiopic/configure.ac')
-rw-r--r--font/misc-ethiopic/configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/font/misc-ethiopic/configure.ac b/font/misc-ethiopic/configure.ac
new file mode 100644
index 000000000..91243e113
--- /dev/null
+++ b/font/misc-ethiopic/configure.ac
@@ -0,0 +1,53 @@
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software
+dnl and its documentation for any purpose is hereby granted without
+dnl fee, provided that the above copyright notice appear in all copies
+dnl and that both that copyright notice and this permission notice
+dnl appear in supporting documentation, and that the name of Red Hat
+dnl not be used in advertising or publicity pertaining to distribution
+dnl of the software without specific, written prior permission. Red
+dnl Hat makes no representations about the suitability of this software
+dnl for any purpose. It is provided "as is" without express or implied
+dnl warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+dnl NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+dnl OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+dnl NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+dnl CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(font-misc-ethiopic, [1.0.0], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], font-misc-ethiopic)
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+AC_PROG_INSTALL
+
+AC_PATH_PROG(MKFONTSCALE, mkfontscale)
+AC_PATH_PROG(MKFONTDIR, mkfontdir)
+AC_PATH_PROG(FCCACHE, fc-cache)
+
+m4_ifdef([AS_HELP_STRING], , [m4_define([AS_HELP_STRING], m4_defn([AC_HELP_STRING]))])
+
+DEFAULT_TTFFONTDIR=${libdir}/X11/fonts/TTF
+AC_ARG_WITH(ttf-fontdir,
+ AS_HELP_STRING([--with-ttf-fontdir=FONTDIR], [Path to install TTF fonts]),
+ [TTFFONTDIR="$withval"],
+ [TTFFONTDIR="$DEFAULT_TTFFONTDIR"])
+AC_SUBST(TTFFONTDIR)
+
+DEFAULT_OTFFONTDIR=${libdir}/X11/fonts/OTF
+AC_ARG_WITH(otf-fontdir,
+ AS_HELP_STRING([--with-otf-fontdir=FONTDIR], [Path to install OTF fonts]),
+ [OTFFONTDIR="$withval"],
+ [OTFFONTDIR="$DEFAULT_OTFFONTDIR"])
+AC_SUBST(OTFFONTDIR)
+
+XORG_RELEASE_VERSION
+
+AC_OUTPUT([Makefile])