summaryrefslogtreecommitdiff
path: root/lib/libX11/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-05-30 19:19:39 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-05-30 19:19:39 +0000
commitc609543baeb9441a4960d26169f6496c2d135d85 (patch)
tree7c83fb94863bdd5011c7b4da53eba6e77296016e /lib/libX11/configure.ac
parent8a451c43839c0f0a10750371d9f75d79b3fe6d59 (diff)
Update to libx11 1.4.2. Tested by ajacoutot@, jasper@ krw@, landry@,
shadchin@ on various architectures. Bump major.
Diffstat (limited to 'lib/libX11/configure.ac')
-rw-r--r--lib/libX11/configure.ac293
1 files changed, 86 insertions, 207 deletions
diff --git a/lib/libX11/configure.ac b/lib/libX11/configure.ac
index 65422c8ef..aa39b38ff 100644
--- a/lib/libX11/configure.ac
+++ b/lib/libX11/configure.ac
@@ -1,39 +1,37 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.60)
-AC_INIT([libX11],
- [1.3.6],
- [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- libX11)
+
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([libX11], [1.4.2],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libX11])
AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([src/config.h include/X11/XlibConf.h])
AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
+# Set common system defines for POSIX extensions, such as _GNU_SOURCE
+# Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
+# to avoid autoconf errors.
+AC_USE_SYSTEM_EXTENSIONS
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER([src/config.h])
-AC_CONFIG_HEADER([include/X11/XlibConf.h])
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
-m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.6 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.6)
+# Initialize libtool
+AC_PROG_LIBTOOL
-# Set common system defines for POSIX extensions, such as _GNU_SOURCE
-# Must be called before any macros that run the compiler (like AC_PROG_LIBTOOL)
-# to avoid autoconf errors.
-AC_USE_SYSTEM_EXTENSIONS
+# Require xorg-macros minimum of 1.11 for disabling fop by default
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.11 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.11)
XORG_DEFAULT_OPTIONS
XORG_ENABLE_SPECS
-XORG_WITH_GROFF
-XORG_WITH_PS2PDF
+XORG_WITH_XMLTO(0.0.20)
+XORG_WITH_FOP([no])
+XORG_CHECK_SGML_DOCTOOLS(1.5)
+XORG_PROG_RAWCPP
-# Checks for programs.
-AC_PROG_LIBTOOL
-DOLT
-AC_PROG_CC
+# Required when PKG_CHECK_MODULES called within an if statement
PKG_PROG_PKG_CONFIG
if test x"$CC_FOR_BUILD" = x; then
@@ -66,64 +64,32 @@ if test x"$LDFLAGS_FOR_BUILD" = x; then
fi
AC_SUBST(LDFLAGS_FOR_BUILD)
-XORG_PROG_RAWCPP
-
-# Find perl for "make check" tests in nls/localerules.in
+# Find perl for "make check" tests in nls/Makefile.am
AC_ARG_WITH(perl,
- AC_HELP_STRING([--with-perl=<path>],
+ AS_HELP_STRING([--with-perl=<path>],
[path to perl interpreter for build-time tests]),
[PERL=$withval ; AC_MSG_CHECKING([perl]) ;
AC_MSG_RESULT([(from --with-perl) $PERL])],
AC_CHECK_PROGS([PERL], [perl], [no]))
AM_CONDITIONAL(HAVE_PERL, test x$PERL != xno)
-# Build with XCB support?
-AC_ARG_WITH(xcb,
- AC_HELP_STRING([--with-xcb], [use XCB for low-level protocol implementation]),
- [ac_cv_use_xcb=$withval], [ac_cv_use_xcb=yes])
-AC_CACHE_CHECK([whether to use XCB], [ac_cv_use_xcb], [ac_cv_use_xcb=yes])
-AM_CONDITIONAL(XCB, test x$ac_cv_use_xcb != xno)
-
# Checks for pkg-config packages
# Always required
-X11_REQUIRES='xproto >= 7.0.13 xextproto xtrans'
+X11_REQUIRES='xproto >= 7.0.13 xextproto xtrans xcb >= 1.1.92'
+X11_EXTRA_DEPS="xcb >= 1.1.92"
PKG_PROG_PKG_CONFIG()
-case "$ac_cv_use_xcb" in
-no)
- X11_REQUIRES="${X11_REQUIRES} xau xcmiscproto bigreqsproto"
- X11_EXTRA_DEPS="xau"
- PKG_CHECK_MODULES(XDMCP, xdmcp,
- AC_CHECK_LIB(Xdmcp, XdmcpWrap,
- [
- AC_CHECK_LIB(Xdmcp, XdmcpWrap, [xdmauth="yes"], [xdmauth="no"], [$XDMCP_LIBS])
- X11_EXTRA_DEPS="$X11_EXTRA_DEPS xdmcp"
- ],
- [
- XDMCP_CFLAGS=
- XDMCP_LIBS=
- ], [$XDMCP_LIBS]),
- [AC_MSG_RESULT(no)])
- AC_DEFINE(USE_XCB, 0, [Use XCB for low-level protocol implementation])
- ;;
-*)
- X11_REQUIRES="${X11_REQUIRES} xcb >= 1.1.92"
- X11_EXTRA_DEPS="xcb >= 1.1.92"
- xdmauth="no" # XCB handles all auth
- AC_DEFINE(USE_XCB, 1, [Use XCB for low-level protocol implementation])
- ;;
-esac
AC_SUBST(X11_EXTRA_DEPS)
-dnl Issue an error if xtrans.m4 was not found and XTRANS_CONNECTION_FLAGS macro
-dnl was not expanded, since libX11 with no transport types is rather useless.
-dnl
-dnl If you're seeing an error here, be sure you installed the lib/xtrans module
-dnl first and if it's not in the default location, that you set the ACLOCAL
-dnl environment variable to find it, such as:
-dnl ACLOCAL="aclocal -I ${PREFIX}/share/aclocal"
+# Issue an error if xtrans.m4 was not found and XTRANS_CONNECTION_FLAGS macro
+# was not expanded, since libX11 with no transport types is rather useless.
+#
+# If you're seeing an error here, be sure you installed the lib/xtrans module
+# first and if it's not in the default location, that you set the ACLOCAL
+# environment variable to find it, such as:
+# ACLOCAL="aclocal -I ${PREFIX}/share/aclocal"
m4_pattern_forbid([^XTRANS_CONNECTION_FLAGS$])
# Transport selection macro from xtrans.m4
@@ -197,7 +163,7 @@ case $host_os in
esac
AC_ARG_WITH(local-transport-order,
- AC_HELP_STRING([--with-local-transport-order=LIST], [preference sorted list of transport types to try for local connections]),
+ AS_HELP_STRING([--with-local-transport-order=LIST], [preference sorted list of transport types to try for local connections]),
[LOCAL_TRANSPORT_LIST=$withval],
[LOCAL_TRANSPORT_LIST=$DEFAULT_LOCAL_TRANS])
AC_DEFINE_UNQUOTED([LOCAL_TRANSPORT_LIST], [$LOCAL_TRANSPORT_LIST],
@@ -227,7 +193,7 @@ AC_MSG_RESULT($HAVE_LOADABLE_MODULES)
AC_MSG_CHECKING([if loadable i18n module support should be enabled])
AC_ARG_ENABLE(loadable-i18n,
- AC_HELP_STRING([--enable-loadable-i18n],
+ AS_HELP_STRING([--enable-loadable-i18n],
[Controls loadable i18n module support]),
[XLIB_LOADABLE_I18N=$enableval],
[XLIB_LOADABLE_I18N="no"])
@@ -245,7 +211,7 @@ AM_CONDITIONAL(XLIB_LOADABLE_I18N, test x$XLIB_LOADABLE_I18N = xyes)
AC_MSG_CHECKING([if loadable Xcursor library support should be enabled])
AC_ARG_ENABLE(loadable-xcursor,
- AC_HELP_STRING([--disable-loadable-xcursor],
+ AS_HELP_STRING([--disable-loadable-xcursor],
[Controls loadable xcursor library support]),
[XLIB_LOADABLE_XCURSOR=$enableval],
[XLIB_LOADABLE_XCURSOR=$HAVE_LOADABLE_MODULES])
@@ -256,7 +222,6 @@ fi
AC_MSG_RESULT($XLIB_LOADABLE_XCURSOR)
# Checks for header files.
-AC_HEADER_STDC
AC_CHECK_HEADERS([sys/select.h])
# Checks for typedefs, structures, and compiler characteristics.
@@ -273,12 +238,12 @@ AC_CHECK_FUNC([getresuid], [XLOCALEDIR_IS_SAFE="yes"]
AC_CHECK_FUNC([shmat], AC_DEFINE(HAS_SHM,1,[Has shm*() functions]))
# Checks for system services
-dnl AC_PATH_XTRA
+# AC_PATH_XTRA
# arch specific things
WCHAR32="1"
-case $target_alias in
- *os2*) os2="true" ; WCHAR32="0" ;;
+case $host_os in
+ os2*) os2="true" ; WCHAR32="0" ;;
*) ;;
esac
AC_SUBST(WCHAR32)
@@ -297,7 +262,7 @@ if test "x$LAUNCHD" = xyes ; then
fi
AC_ARG_ENABLE(xthreads,
- AC_HELP_STRING([--disable-xthreads],
+ AS_HELP_STRING([--disable-xthreads],
[Disable Xlib support for Multithreading]),
[xthreads=$enableval],[xthreads=yes])
@@ -318,7 +283,7 @@ esac
AC_CHECK_LIB(c, pthread_self, [thrstubs="no"], [thrstubs="yes"])
AM_CONDITIONAL(THRSTUBS, test x$thrstubs = xyes)
-dnl XXX incomplete, please fill this in
+# XXX incomplete, please fill this in
if test x$xthreads = xyes ; then
case $host_os in
linux*|openbsd*|gnu*|k*bsd*-gnu)
@@ -338,17 +303,6 @@ fi
AC_SUBST(XTHREADLIB)
AC_SUBST(XTHREAD_CFLAGS)
-case x$xdmauth in
-xyes)
- XDMCP_CFLAGS="$XDMCP_CFLAGS -DHASXDMAUTH"
- ;;
-xno)
- XDMCP_LIBS=""
- ;;
-esac
-AC_SUBST(XDMCP_CFLAGS)
-AC_SUBST(XDMCP_LIBS)
-
AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL, 1, [poll() function is available])], )
#
@@ -370,7 +324,7 @@ AC_SUBST(KEYSYMDEFS)
AM_CONDITIONAL(UDC, test xfalse = xtrue)
AC_ARG_ENABLE(xcms,
- AC_HELP_STRING([--disable-xcms],
+ AS_HELP_STRING([--disable-xcms],
[Disable Xlib support for CMS *EXPERIMENTAL*]),
[XCMS=$enableval],[XCMS=yes])
AM_CONDITIONAL(XCMS, [test x$XCMS = xyes ])
@@ -379,7 +333,7 @@ if test x"$XCMS" = "xyes"; then
fi
AC_ARG_ENABLE(xlocale,
- AC_HELP_STRING([--disable-xlocale],
+ AS_HELP_STRING([--disable-xlocale],
[Disable Xlib locale implementation *EXPERIMENTAL*]),
[XLOCALE=$enableval],[XLOCALE=yes])
@@ -393,7 +347,7 @@ fi
# clients that are setgid or setuid to an id other than 0.
AC_MSG_CHECKING([if XLOCALEDIR support should be enabled])
AC_ARG_ENABLE(xlocaledir,
- AC_HELP_STRING([--enable-xlocaledir],
+ AS_HELP_STRING([--enable-xlocaledir],
[Enable XLOCALEDIR environment variable support]),
[ENABLE_XLOCALEDIR=$enableval],[ENABLE_XLOCALEDIR=$XLOCALEDIR_IS_SAFE])
if test "x$ENABLE_XLOCALEDIR" = "xno"; then
@@ -402,32 +356,19 @@ fi
AC_MSG_RESULT($ENABLE_XLOCALEDIR)
AC_ARG_ENABLE(xf86bigfont,
- AC_HELP_STRING([--disable-xf86bigfont],
+ AS_HELP_STRING([--disable-xf86bigfont],
[Disable XF86BigFont extension support]),
[XF86BIGFONT=$enableval],[XF86BIGFONT="yes"])
if test "x$XF86BIGFONT" = "xyes"; then
- PKG_CHECK_MODULES(BIGFONT, xf86bigfontproto,
+ PKG_CHECK_MODULES(BIGFONT, [xf86bigfontproto >= 1.2.0],
AC_DEFINE(XF86BIGFONT,1,[Enable XF86BIGFONT extension]),XF86BIGFONT="no")
- AC_SUBST(BIGFONT_CFLAGS)
- AC_SUBST(BIGFONT_LIBS)
fi
AC_ARG_ENABLE(xkb,
- AC_HELP_STRING([--disable-xkb],
+ AS_HELP_STRING([--disable-xkb],
[Disable XKB support *EXPERIMENTAL*]),
[XKB=$enableval],[XKB=yes])
-AC_ARG_ENABLE(man-pages,
- AC_HELP_STRING([--enable-man-pages=section],
- [Choose manual section for installing man pages]),
- [LIBMAN=$enableval],[LIBMAN=yes])
-
-if test "x$LIBMAN" != "xyes"; then
- LIB_MAN_SUFFIX=$LIBMAN
-fi
-
-AM_CONDITIONAL(MANPAGES, [ test x$LIBMAN '!=' xno ])
-
AM_CONDITIONAL(XKB, [ test x$XKB = xyes ])
if test x"$XKB" = "xyes"; then
XKBPROTO_REQUIRES="kbproto"
@@ -442,19 +383,19 @@ AC_FUNC_MMAP()
composecache_default=$ac_cv_func_mmap_fixed_mapped
AC_CHECK_FUNC(nl_langinfo, , [composecache_default=no])
AC_ARG_ENABLE(composecache,
- AC_HELP_STRING([--disable-composecache],
+ AS_HELP_STRING([--disable-composecache],
[Disable compose table cache support]),
[COMPOSECACHE=$enableval],[COMPOSECACHE=$composecache_default])
if test x"$COMPOSECACHE" = "xyes"; then
AC_DEFINE(COMPOSECACHE,1,[Include compose table cache support])
fi
-dnl Allow checking code with lint, sparse, etc.
+# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
XORG_LINT_LIBRARY([X11])
X11_DATADIR="${datadir}/X11"
-AC_DEFINE_DIR(X11_DATADIR, X11_DATADIR, [Location of libX11 data])
+AX_DEFINE_DIR(X11_DATADIR, X11_DATADIR, [Location of libX11 data])
AC_SUBST(X11_DATADIR)
X11_LIBDIR="${libdir}/X11"
@@ -473,125 +414,64 @@ X11_CFLAGS="$X11_CFLAGS $XTHREAD_CFLAGS"
#
X11_LOCALEDATADIR="${X11_DATADIR}/locale"
-AC_DEFINE_DIR(XLOCALEDATADIR, X11_LOCALEDATADIR, [Location of libX11 locale data])
+AX_DEFINE_DIR(XLOCALEDATADIR, X11_LOCALEDATADIR, [Location of libX11 locale data])
AC_SUBST(X11_LOCALEDATADIR)
AC_ARG_WITH(locale-lib-dir, AS_HELP_STRING([--with-locale-lib-dir=DIR],
[Directory where locale libraries files are installed (default: $libdir/X11/locale)]),
[ X11_LOCALELIBDIR="$withval" ],
[ X11_LOCALELIBDIR="${X11_LIBDIR}/locale" ])
-AC_DEFINE_DIR(XLOCALELIBDIR, X11_LOCALELIBDIR, [Location of libX11 locale libraries])
+AX_DEFINE_DIR(XLOCALELIBDIR, X11_LOCALELIBDIR, [Location of libX11 locale libraries])
AC_SUBST(X11_LOCALELIBDIR)
X11_LOCALEDIR="${X11_LOCALEDATADIR}"
-AC_DEFINE_DIR(XLOCALEDIR, X11_LOCALEDIR, [Location of libX11 locale data])
+AX_DEFINE_DIR(XLOCALEDIR, X11_LOCALEDIR, [Location of libX11 locale data])
AC_SUBST(X11_LOCALEDIR)
XKEYSYMDB="${X11_DATADIR}/XKeysymDB"
-AC_DEFINE_DIR(XKEYSYMDB, XKEYSYMDB, [Location of keysym database])
+AX_DEFINE_DIR(XKEYSYMDB, XKEYSYMDB, [Location of keysym database])
XERRORDB="${X11_DATADIR}/XErrorDB"
-AC_DEFINE_DIR(XERRORDB, XERRORDB, [Location of error message database])
+AX_DEFINE_DIR(XERRORDB, XERRORDB, [Location of error message database])
XORG_CHECK_MALLOC_ZERO
-AC_OUTPUT([Makefile
- include/Makefile
- man/Makefile
- man/xkb/Makefile
- src/Makefile
- src/util/Makefile
- src/xcms/Makefile
- src/xlibi18n/Makefile
- modules/Makefile
- modules/im/Makefile
- modules/im/ximcp/Makefile
- modules/lc/Makefile
- modules/lc/def/Makefile
- modules/lc/gen/Makefile
- modules/lc/Utf8/Makefile
- modules/lc/xlocale/Makefile
- modules/om/Makefile
- modules/om/generic/Makefile
- src/xkb/Makefile
- nls/Makefile
- nls/am_ET.UTF-8/Makefile
- nls/armscii-8/Makefile
- nls/C/Makefile
- nls/el_GR.UTF-8/Makefile
- nls/en_US.UTF-8/Makefile
- nls/fi_FI.UTF-8/Makefile
- nls/georgian-academy/Makefile
- nls/georgian-ps/Makefile
- nls/ibm-cp1133/Makefile
- nls/iscii-dev/Makefile
- nls/isiri-3342/Makefile
- nls/iso8859-1/Makefile
- nls/iso8859-10/Makefile
- nls/iso8859-11/Makefile
- nls/iso8859-13/Makefile
- nls/iso8859-14/Makefile
- nls/iso8859-15/Makefile
- nls/iso8859-2/Makefile
- nls/iso8859-3/Makefile
- nls/iso8859-4/Makefile
- nls/iso8859-5/Makefile
- nls/iso8859-6/Makefile
- nls/iso8859-7/Makefile
- nls/iso8859-8/Makefile
- nls/iso8859-9/Makefile
- nls/iso8859-9e/Makefile
- nls/ja/Makefile
- nls/ja.JIS/Makefile
- nls/ja_JP.UTF-8/Makefile
- nls/ja.S90/Makefile
- nls/ja.SJIS/Makefile
- nls/ja.U90/Makefile
- nls/ko/Makefile
- nls/koi8-c/Makefile
- nls/koi8-r/Makefile
- nls/koi8-u/Makefile
- nls/ko_KR.UTF-8/Makefile
- nls/microsoft-cp1251/Makefile
- nls/microsoft-cp1255/Makefile
- nls/microsoft-cp1256/Makefile
- nls/mulelao-1/Makefile
- nls/nokhchi-1/Makefile
- nls/pt_BR.UTF-8/Makefile
- nls/ru_RU.UTF-8/Makefile
- nls/tatar-cyr/Makefile
- nls/th_TH/Makefile
- nls/th_TH.UTF-8/Makefile
- nls/tscii-0/Makefile
- nls/vi_VN.tcvn/Makefile
- nls/vi_VN.viscii/Makefile
- nls/zh_CN/Makefile
- nls/zh_CN.gb18030/Makefile
- nls/zh_CN.gbk/Makefile
- nls/zh_CN.UTF-8/Makefile
- nls/zh_HK.big5/Makefile
- nls/zh_HK.big5hkscs/Makefile
- nls/zh_HK.UTF-8/Makefile
- nls/zh_TW/Makefile
- nls/zh_TW.big5/Makefile
- nls/zh_TW.UTF-8/Makefile
- specs/Makefile
- specs/i18n/Makefile
- specs/libX11/Makefile
- specs/XIM/Makefile
- x11.pc
- x11-xcb.pc])
-
-man_pages_suffix=$LIB_MAN_SUFFIX
-if test -z "$man_pages_suffix"; then
- man_pages_suffix=none
-fi
+AC_CONFIG_FILES([Makefile
+ include/Makefile
+ man/Makefile
+ man/xkb/Makefile
+ src/Makefile
+ src/util/Makefile
+ src/xcms/Makefile
+ src/xlibi18n/Makefile
+ modules/Makefile
+ modules/im/Makefile
+ modules/im/ximcp/Makefile
+ modules/lc/Makefile
+ modules/lc/def/Makefile
+ modules/lc/gen/Makefile
+ modules/lc/Utf8/Makefile
+ modules/lc/xlocale/Makefile
+ modules/om/Makefile
+ modules/om/generic/Makefile
+ src/xkb/Makefile
+ nls/Makefile
+ specs/Makefile
+ specs/i18n/Makefile
+ specs/i18n/framework/Makefile
+ specs/i18n/localedb/Makefile
+ specs/i18n/trans/Makefile
+ specs/libX11/Makefile
+ specs/XIM/Makefile
+ specs/XKB/Makefile
+ x11.pc
+ x11-xcb.pc])
+AC_OUTPUT
echo ""
echo "X11 will be built with the following settings:"
echo " Loadable i18n module support: "$XLIB_LOADABLE_I18N
echo " Loadable xcursor library support: "$XLIB_LOADABLE_XCURSOR
-echo " Use XCB: "$ac_cv_use_xcb
echo " Threading support: "$xthreads
echo " Use Threads safe API: "$mtsafeapi
echo " Threads stubs in libX11: "$thrstubs
@@ -600,7 +480,6 @@ echo " Internationalization support: "$XLOCALE
echo " XF86BigFont support: "$XF86BIGFONT
echo " XKB support: "$XKB
echo " XLOCALEDIR environment variable support: "$ENABLE_XLOCALEDIR
-echo " Manual pages suffix: "$man_pages_suffix
echo " Compose table cache enabled: "$COMPOSECACHE
echo " Functional specs building enabled: "$build_specs
echo ""