summaryrefslogtreecommitdiff
path: root/lib/libXRes/man/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:50:27 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:50:27 +0000
commit3a046c5ec4d35db83ec5561db7620a4cc1d0c5ce (patch)
treef38c782b144e9e5e9bd08b0d08832406d91c214b /lib/libXRes/man/Makefile.am
parent3dfd0ca9ef1ab98477502e78a3066a814e527cb8 (diff)
import from X.Org 7.2RC1
Diffstat (limited to 'lib/libXRes/man/Makefile.am')
-rw-r--r--lib/libXRes/man/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/lib/libXRes/man/Makefile.am b/lib/libXRes/man/Makefile.am
new file mode 100644
index 000000000..f5fac3fd7
--- /dev/null
+++ b/lib/libXRes/man/Makefile.am
@@ -0,0 +1,75 @@
+# $Id: Makefile.am,v 1.1 2006/11/25 16:50:26 matthieu Exp $
+#
+# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation.
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+# IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
+# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+# Except as contained in this notice, the name of the copyright holders shall
+# not be used in advertising or otherwise to promote the sale, use or
+# other dealings in this Software without prior written authorization
+# from the copyright holders.
+#
+
+libmandir = $(LIB_MAN_DIR)
+
+LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
+
+libman_PRE = XRes.man
+
+BUILT_SOURCES = shadows.DONE
+
+EXTRA_DIST = $(libman_PRE)
+
+CLEANFILES = $(libman_DATA) $(BUILT_SOURCES)
+
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@) \
+ $(XRes_shadows:=.@LIB_MAN_SUFFIX@)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's/__vendorversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
+ -e 's/__xservername__/Xorg/g' \
+ -e 's/__xconfigfile__/xorg.conf/g' \
+ -e 's/__miscmansuffix__/$(MISC_MAN_SUFFIX)/g' \
+ -e 's/__libmansuffix__/$(LIB_MAN_SUFFIX)/g' \
+ -e 's/__filemansuffix__/$(FILE_MAN_SUFFIX)/g'
+
+SUFFIXES = .$(LIB_MAN_SUFFIX) .man
+
+.man.$(LIB_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+
+# Generate man page shadow files (Replaces InstallManPageAliases from Imake)
+
+XRes_shadows = \
+ XResQueryExtension \
+ XResQueryVersion \
+ XResQueryClients \
+ XResQueryClientResources \
+ XResQueryClientPixmapBytes
+
+shadows.DONE:
+ -rm -f $(XRes_shadows:=.@LIB_MAN_SUFFIX@)
+ (for i in $(XRes_shadows:=.@LIB_MAN_SUFFIX@) ; do \
+ echo .so man$(LIB_MAN_DIR_SUFFIX)/XRes.$(LIB_MAN_SUFFIX) > $$i; \
+ done)