summaryrefslogtreecommitdiff
path: root/lib/libXau/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:56:39 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:56:39 +0000
commit2e4c23f58853bcf4ff63dbbaeb8782c7868e48f7 (patch)
treeeb644144d6e55acfb988211a51fdb94013cdcaa5 /lib/libXau/configure.ac
parentd500aedc10e37435d8a24b2a9de02422a989726c (diff)
import from X.Org 7.2RC2
Diffstat (limited to 'lib/libXau/configure.ac')
-rw-r--r--lib/libXau/configure.ac76
1 files changed, 76 insertions, 0 deletions
diff --git a/lib/libXau/configure.ac b/lib/libXau/configure.ac
new file mode 100644
index 000000000..ac1110748
--- /dev/null
+++ b/lib/libXau/configure.ac
@@ -0,0 +1,76 @@
+dnl
+dnl $Id: configure.ac,v 1.1 2006/11/25 16:54:53 matthieu Exp $
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(libXau, 1.0.1, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],libXau)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+AC_PROG_MAKE_SET
+
+PKG_CHECK_MODULES(XAU, xproto)
+AC_SUBST(XAU_CFLAGS)
+AC_SUBST(XAU_LIBS)
+
+kerberos=false
+AM_CONDITIONAL(KERBEROS, test x$kerberos = xtrue)
+
+AC_ARG_ENABLE(xthreads,
+ AC_HELP_STRING([--disable-xthreads],
+ [Disable libXau support for Multithreading]),
+ [xthreads=$enableval],[xthreads=yes])
+
+if test "x$xthreads" = "xyes" ; then
+ AC_DEFINE(XTHREADS,1,[Whether libXau is compiled with thread support])
+ AC_CHECK_LIB(c, gethostbyname_r, AC_DEFINE(XUSE_MTSAFE_API,1,
+ [Whether libXau needs to use MT safe API's]))
+
+dnl XXX incomplete, please fill this in
+ case $host_os in
+ solaris*)
+ XTHREAD_CFLAGS="-D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS" ;;
+ esac
+ XAU_CFLAGS="$XAU_CFLAGS $XTHREAD_CFLAGS"
+fi
+
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+ XAU_CFLAGS="$GCC_WARNINGS $XAU_CFLAGS"
+fi
+
+XORG_MANPAGE_SECTIONS
+XORG_RELEASE_VERSION
+
+AC_OUTPUT([Makefile
+ xau.pc])