summaryrefslogtreecommitdiff
path: root/lib/libXrandr/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 17:37:53 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 17:37:53 +0000
commita4022064ccd7746bc1bc412af39a85cddc10fee0 (patch)
tree713746d2f42c893b55505509831e70c9e07d8b58 /lib/libXrandr/configure.ac
parent7cf62c518e939f6c1aefe3b470dda09debfacd7f (diff)
import from X.Org 7.2RC1
Diffstat (limited to 'lib/libXrandr/configure.ac')
-rw-r--r--lib/libXrandr/configure.ac67
1 files changed, 67 insertions, 0 deletions
diff --git a/lib/libXrandr/configure.ac b/lib/libXrandr/configure.ac
new file mode 100644
index 000000000..ad7dc67d8
--- /dev/null
+++ b/lib/libXrandr/configure.ac
@@ -0,0 +1,67 @@
+dnl
+dnl $Id: configure.ac,v 1.1 2006/11/25 17:37:37 matthieu Exp $
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+dnl
+dnl Version should match the current Render version. XRenderQueryVersion
+dnl returns the version from randr.h, NOT the version we set here. But we
+dnl try to keep these the same. Note that the library has an extra
+dnl digit in the version number to track changes which don't affect the
+dnl protocol, so Xrandr version l.n.m corresponds to protocol version l.n
+dnl
+AC_INIT(libXrandr, 1.1.2, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXrandr)
+AC_CONFIG_AUX_DIR(.)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+# Check for X
+PKG_CHECK_MODULES(X, x11)
+AC_SUBST(X_CFLAGS)
+AC_SUBST(X_LIBS)
+
+# Check randr configuration, strip extra digits from package version to
+# find the required protocol version
+
+RANDR_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
+AC_SUBST(RANDR_VERSION)
+PKG_CHECK_MODULES(RANDR, randrproto >= $RANDR_VERSION xext xextproto xrender renderproto)
+AC_SUBST(RANDR_CFLAGS)
+AC_SUBST(RANDR_LIBS)
+
+XORG_CHECK_MALLOC_ZERO
+XORG_MANPAGE_SECTIONS
+XORG_RELEASE_VERSION
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ man/Makefile
+ xrandr.pc])