summaryrefslogtreecommitdiff
path: root/lib/libXt/test/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2012-03-10 16:45:50 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2012-03-10 16:45:50 +0000
commitcc7d66bfcf0d3305ee962a167dd9f4338266ebec (patch)
treebae58760726ce0b349447cac2b5c1859c4737c0f /lib/libXt/test/Makefile.am
parenta5008d58b42532ef26fa9a62407a31e9991a0e39 (diff)
Update to libXt 1.1.2
Diffstat (limited to 'lib/libXt/test/Makefile.am')
-rw-r--r--lib/libXt/test/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/libXt/test/Makefile.am b/lib/libXt/test/Makefile.am
new file mode 100644
index 000000000..7494c4147
--- /dev/null
+++ b/lib/libXt/test/Makefile.am
@@ -0,0 +1,14 @@
+if ENABLE_UNIT_TESTS
+if HAVE_GLIB
+check_PROGRAMS = Alloc Converters Event
+
+TESTS=$(check_PROGRAMS)
+
+AM_CFLAGS = $(CWARNFLAGS) $(XT_CFLAGS) $(GLIB_CFLAGS)
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include
+LDADD= $(top_builddir)/src/libXt.la $(GLIB_LIBS)
+
+TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
+
+endif HAVE_GLIB
+endif ENABLE_UNIT_TESTS