summaryrefslogtreecommitdiff
path: root/lib/libXv/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:08:14 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:08:14 +0000
commit1d13d3921dd70a5ff2f0784c47e7dbd192b778a2 (patch)
tree9961a7d26f83ba33a7850a82b03660e0d49f71aa /lib/libXv/configure.ac
parent690dcb448242e6a81154e589bb283f1e98f38c67 (diff)
import from X.Org 7.2RC2
Diffstat (limited to 'lib/libXv/configure.ac')
-rw-r--r--lib/libXv/configure.ac61
1 files changed, 61 insertions, 0 deletions
diff --git a/lib/libXv/configure.ac b/lib/libXv/configure.ac
new file mode 100644
index 000000000..a3913b811
--- /dev/null
+++ b/lib/libXv/configure.ac
@@ -0,0 +1,61 @@
+dnl
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+AC_INIT(libXv, 1.0.2, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXv)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+# Require xorg-macros version 1.1.0 or newer for XORG_WITH_LINT macro
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.1 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.1)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+# Check for dependencies
+PKG_CHECK_MODULES(XV, x11 xext xextproto videoproto)
+
+AC_SUBST(XV_CFLAGS)
+AC_SUBST(XV_LIBS)
+
+XORG_CHECK_MALLOC_ZERO
+XORG_MANPAGE_SECTIONS
+XORG_RELEASE_VERSION
+
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+XORG_LINT_LIBRARY([Xv])
+LINT_FLAGS="${LINT_FLAGS} ${XV_CFLAGS}"
+
+AC_OUTPUT([Makefile
+ include/Makefile
+ include/X11/Makefile
+ include/X11/extensions/Makefile
+ src/Makefile
+ man/Makefile
+ xv.pc])