summaryrefslogtreecommitdiff
path: root/lib/libpciaccess/man/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-11-06 21:35:47 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-11-06 21:35:47 +0000
commitc04f9647b366b5bae25ebe865489399f694345b9 (patch)
tree5e513e57d0d80c932163bed06b2d8bc4aee0a1bf /lib/libpciaccess/man/Makefile.am
parentbf30bb6f25b5a60fcdc0ea42af9925d32f1197c1 (diff)
Update to libpciaccess 0.12.1. Ok kettenis@, shadchin@
Diffstat (limited to 'lib/libpciaccess/man/Makefile.am')
-rw-r--r--lib/libpciaccess/man/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/lib/libpciaccess/man/Makefile.am b/lib/libpciaccess/man/Makefile.am
new file mode 100644
index 000000000..45edd457f
--- /dev/null
+++ b/lib/libpciaccess/man/Makefile.am
@@ -0,0 +1,34 @@
+#
+# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+#
+
+appman_PRE = scanpci.man
+noinst_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(noinst_DATA)
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@