summaryrefslogtreecommitdiff
path: root/lib/libxkbfile/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:24:52 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:24:52 +0000
commita8bfe281f57c7f53a48db78e8eaea1e391dacb52 (patch)
tree5f80a6626e4eebe1d1202fcaa0c94e1f506b0dab /lib/libxkbfile/configure.ac
parenta98798b5281d3dd9c234a8feab82721ab17a241e (diff)
import from X.Org 7.2RC1
Diffstat (limited to 'lib/libxkbfile/configure.ac')
-rw-r--r--lib/libxkbfile/configure.ac49
1 files changed, 49 insertions, 0 deletions
diff --git a/lib/libxkbfile/configure.ac b/lib/libxkbfile/configure.ac
new file mode 100644
index 000000000..673bccf06
--- /dev/null
+++ b/lib/libxkbfile/configure.ac
@@ -0,0 +1,49 @@
+
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+AC_INIT(libxkbfile, 1.0.4, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libxkbfile)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+AC_CHECK_FUNC(strcasecmp, [], AC_DEFINE([NEED_STRCASECMP], 1,
+ [Do not have `strcasecmp'.]))
+
+# Check for dependencies
+PKG_CHECK_MODULES(XKBFILE, x11 kbproto)
+
+AC_SUBST(XKBFILE_CFLAGS)
+AC_SUBST(XKBFILE_LIBS)
+
+XORG_RELEASE_VERSION
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ xkbfile.pc])