summaryrefslogtreecommitdiff
path: root/lib/libxtrans/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-31 20:34:08 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-31 20:34:08 +0000
commit1a851c206445bbb29016d2af28393fdfa45c62d7 (patch)
tree13437a11ff14b495e4c5513da0ebdd97399cba07 /lib/libxtrans/Makefile.am
parentd102f95642350eb29acafffbaa4414704121537d (diff)
Update to xtrans 1.2.5
Diffstat (limited to 'lib/libxtrans/Makefile.am')
-rw-r--r--lib/libxtrans/Makefile.am48
1 files changed, 45 insertions, 3 deletions
diff --git a/lib/libxtrans/Makefile.am b/lib/libxtrans/Makefile.am
index 07e01538b..fa6ef1515 100644
--- a/lib/libxtrans/Makefile.am
+++ b/lib/libxtrans/Makefile.am
@@ -12,12 +12,12 @@ Xtransinclude_HEADERS = \
aclocaldir = $(datadir)/aclocal
aclocal_DATA = xtrans.m4
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(datadir)/pkgconfig
pkgconfig_DATA = xtrans.pc
-EXTRA_DIST = xtrans.pc.in ${aclocal_DATA}
+EXTRA_DIST = xtrans.pc.in ${aclocal_DATA} ChangeLog Xtrans.mm
-CLEANFILES = ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
@@ -25,3 +25,45 @@ ChangeLog:
$(CHANGELOG_CMD)
dist-hook: ChangeLog
+
+# Rules to convert documentation from troff to other formats
+doc_sources = Xtrans.mm
+
+if HAVE_PS2PDF
+printable_format = .pdf
+else
+printable_format = .ps
+endif
+
+if BUILD_DOCS
+doc_DATA = $(doc_sources:.mm=.txt) \
+ $(doc_sources:.mm=$(printable_format)) \
+ $(doc_sources:.mm=.html)
+
+CLEANFILES = $(doc_DATA)
+MOSTLYCLEANFILES = index.*
+
+# Pass version string as a troff string for substitution
+GROFF_DEFS = -dxV="$(PACKAGE_STRING)"
+
+# -t to run through tbl
+GROFF_FLAGS = -t -mm $(GROFF_DEFS)
+
+SUFFIXES = .mm .ps .txt .html .pdf
+
+.mm.ps:
+ -$(AM_V_GEN) $(GROFF) -Tps $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+ @if grep '^[^1-9.]' index.$@.raw | grep -v warning; then exit 1; \
+ else test $$? -le 1; fi
+
+.mm.txt:
+ $(AM_V_GEN) env GROFF_NO_SGR=TRUE $(GROFF) -Tutf8 $(GROFF_FLAGS) \
+ $< 2> index.$@.raw > $@
+
+.mm.html:
+ $(AM_V_GEN) $(GROFF) -Thtml $(GROFF_FLAGS) $< 2> index.$@.raw > $@
+
+.ps.pdf:
+ $(AM_V_GEN) $(PS2PDF) $< $@
+
+endif BUILD_DOCS