summaryrefslogtreecommitdiff
path: root/lib/mesa/src/mapi/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2018-10-23 06:36:00 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2018-10-23 06:36:00 +0000
commitb65fcab046d3a1b6b6ac315720df220925c5322e (patch)
treeff73dcc383ac0799c655ff6194cda9dacb75dde9 /lib/mesa/src/mapi/Makefile.am
parent18d6381c51e253e4c41c62619f80d9ce745b95c8 (diff)
Merge Mesa 17.3.9
Mesa 18.x needs an ld with build-id for at least the intel code Mesa 18.2 assumes linux only memfd syscalls in intel code Tested by matthieu@, kettenis@ and myself on a variety of hardware and architectures. ok kettenis@
Diffstat (limited to 'lib/mesa/src/mapi/Makefile.am')
-rw-r--r--lib/mesa/src/mapi/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/lib/mesa/src/mapi/Makefile.am b/lib/mesa/src/mapi/Makefile.am
index 0e3dab993..096e1d0bd 100644
--- a/lib/mesa/src/mapi/Makefile.am
+++ b/lib/mesa/src/mapi/Makefile.am
@@ -47,7 +47,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/src \
-I$(top_builddir)/src/mapi \
- -I$(top_srcdir)/src/mapi
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_builddir)/src/mapi/glapi \
+ -I$(top_srcdir)/src/mapi/glapi
include Makefile.sources
@@ -94,7 +96,7 @@ endif
if REGEN_SOURCES
shared-glapi/glapi_mapi_tmp.h : glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
$(MKDIR_GEN)
- $(PYTHON_GEN) $(srcdir)/mapi_abi.py --mode lib --printer shared-glapi \
+ $(PYTHON_GEN) $(srcdir)/mapi_abi.py --printer shared-glapi \
$(srcdir)/glapi/gen/gl_and_es_API.xml > $@
endif
@@ -115,7 +117,6 @@ endif
glapi_libglapi_la_SOURCES =
glapi_libglapi_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
- -I$(top_srcdir)/src/mapi/glapi \
-I$(top_srcdir)/src/mesa
if HAVE_APPLEDRI
@@ -189,15 +190,13 @@ es1api_libGLESv1_CM_la_LDFLAGS = \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)
-if HAVE_SHARED_GLAPI
es1api_libGLESv1_CM_la_LIBADD += shared-glapi/libglapi.la
endif
-endif
if REGEN_SOURCES
es1api/glapi_mapi_tmp.h: glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
$(MKDIR_GEN)
- $(PYTHON_GEN) $(srcdir)/mapi_abi.py --mode lib --printer es1api \
+ $(PYTHON_GEN) $(srcdir)/mapi_abi.py --printer es1api \
$(srcdir)/glapi/gen/gl_and_es_API.xml > $@
endif
@@ -238,16 +237,19 @@ es2api_libGLESv2_la_LDFLAGS = \
$(GC_SECTIONS) \
$(LD_NO_UNDEFINED)
-if HAVE_SHARED_GLAPI
es2api_libGLESv2_la_LIBADD += shared-glapi/libglapi.la
endif
-endif
if REGEN_SOURCES
es2api/glapi_mapi_tmp.h: glapi/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
$(MKDIR_GEN)
- $(PYTHON_GEN) $(srcdir)/mapi_abi.py --mode lib --printer es2api \
+ $(PYTHON_GEN) $(srcdir)/mapi_abi.py --printer es2api \
$(srcdir)/glapi/gen/gl_and_es_API.xml > $@
endif
include $(top_srcdir)/install-lib-links.mk
+
+if NEED_KHRPLATFORM
+khrdir = $(includedir)/KHR
+khr_HEADERS = $(top_srcdir)/include/KHR/khrplatform.h
+endif