summaryrefslogtreecommitdiff
path: root/util/imake/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 16:54:25 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 16:54:25 +0000
commitdaa4750bdd3405236ae1057debc9c72d3b3bdb99 (patch)
tree7f533afe7e88c311c6f7a36a2500a371041dfaf5 /util/imake/Makefile.am
parentd7e38bf83f06dde41591f6e844e56a1d36528703 (diff)
Update to imake 1.0.4. No functional change.
Diffstat (limited to 'util/imake/Makefile.am')
-rw-r--r--util/imake/Makefile.am23
1 files changed, 3 insertions, 20 deletions
diff --git a/util/imake/Makefile.am b/util/imake/Makefile.am
index 1fe351db1..6a932f3b5 100644
--- a/util/imake/Makefile.am
+++ b/util/imake/Makefile.am
@@ -125,30 +125,13 @@ appman_PRE = \
mkhtmlindex.man
# Only need to install man pages for programs/scripts being installed
-appman_needed_for = $(bin_PROGRAMS) $(bin_SCRIPTS)
-appman_DATA = $(appman_needed_for:%=%.@APP_MAN_SUFFIX@)
+appman_DATA = $(bin_PROGRAMS:%$(EXEEXT)=%.@APP_MAN_SUFFIX@) $(bin_SCRIPTS:%=%.@APP_MAN_SUFFIX@)
EXTRA_DIST += $(appman_PRE)
CLEANFILES += $(appman_DATA)
-SED = sed
-
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xservername__|Xorg|g' \
- -e 's|__xconfigfile__|xorg.conf|g' \
- -e 's|__projectroot__|$(prefix)|g' \
- -e 's|__apploaddir__|$(appdefaultdir)|' \
- -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
- -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
- -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
- -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
- -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g' \
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+MAN_SUBSTS += \
-e 's|__cpp__|$(RAWCPP)|g'
SUFFIXES = .$(APP_MAN_SUFFIX) .man