summaryrefslogtreecommitdiff
path: root/xserver/hw/kdrive/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2007-05-25 15:47:17 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2007-05-25 15:47:17 +0000
commit0ac7cf03b9345f722c7fe7376ac6ed1dae3282f8 (patch)
tree3686450cd315de9499fe533c5865fc5fe9213aa3 /xserver/hw/kdrive/Makefile.am
parentee0eb82d3f507e1f9804c386c44fcd09b652638d (diff)
required bits to build Xwscons
Diffstat (limited to 'xserver/hw/kdrive/Makefile.am')
-rw-r--r--xserver/hw/kdrive/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/xserver/hw/kdrive/Makefile.am b/xserver/hw/kdrive/Makefile.am
index c8832ebac..56e85a059 100644
--- a/xserver/hw/kdrive/Makefile.am
+++ b/xserver/hw/kdrive/Makefile.am
@@ -7,6 +7,10 @@ if KDRIVEFBDEV
FBDEV_SUBDIRS = fbdev
endif
+if KDRIVEWSCONS
+WSCONS_SUBDIRS = wscons
+endif
+
if XSDLSERVER
XSDL_SUBDIRS = sdl
endif
@@ -15,14 +19,25 @@ if XEPHYR
XEPHYR_SUBDIRS = ephyr
endif
+if KDRIVELINUX
+LINUX_SUBDIRS = linux
+endif
+
+if KDRIVEOPENBSD
+OPENBSD_SUBDIRS = openbsd
+endif
+
SUBDIRS = \
src \
- linux \
+ $(LINUX_SUBDIRS) \
+ $(OPENBSD_SUBDIRS) \
$(XSDL_SUBDIRS) \
$(FBDEV_SUBDIRS) \
$(VESA_SUBDIRS) \
+ $(WSCONS_SUBDIRS) \
$(XEPHYR_SUBDIRS) \
fake
DIST_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
- smi via fbdev sdl ephyr src linux fake sis300
+ smi via fbdev sdl ephyr src linux fake sis300 \
+ openbsd wscons