summaryrefslogtreecommitdiff
path: root/app/beforelight/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/beforelight/configure.ac')
-rw-r--r--app/beforelight/configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/app/beforelight/configure.ac b/app/beforelight/configure.ac
index 472d4c749..67514b0e5 100644
--- a/app/beforelight/configure.ac
+++ b/app/beforelight/configure.ac
@@ -21,10 +21,15 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([beforelight], [1.0.4],
+AC_INIT([beforelight], [1.0.5],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
[beforelight])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -34,19 +39,19 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER(config.h)
-
# Checks for pkg-config packages
PKG_CHECK_MODULES(BEFORELIGHT, x11 xscrnsaver xt)
-PKG_CHECK_MODULES(XAW, xaw7)
PKG_CHECK_MODULES(APPDEFS, xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,
- AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ AS_HELP_STRING([--with-appdefaultdir=<pathname>],
[specify directory for app-defaults files (default is autodetected)]),
[appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT